Jump to content

[Newbie] MicroSD showing as "No Media".


Recommended Posts

I received my USB Rubber Ducky Deluxe Kit in the post today and I've come across my first problem. I cannot follow any of the guides or help topics or do anything with it at all because it seems like the SD card is non existant. I've tried the MicroSD reader with my own 32GB MicroSD and it works fine, but the 256MB just comes up as "No Media". I cannot format the disk or do anything with it at all. I've been searching online in vain for something to help. Have I just missed a blatant step or is something seriously wrong?

Steps To Reproduce: Place MicroSD card in card reader and plug into PC.

Expected Result: Somewhere to put my inject.bin.

Actual Result: Nothing at all. Not even compmgmt.msc can find anything on it.

Screenshots:

Link to comment
Share on other sites

Sounds like another dead micro sdcard, my advice is contact the hakshop about replacing the sdcard.

As an alternative, micro sdcards are pretty cheap and can be obtained from camera shops/supermarkets or ebay/amazon for as little as $3.

I haven't tried the ducky with a 32GB sdcard, but I had plenty of old sdcards lying around from old motorola/htc phones. I've successfully used a different number of cards ranging from 64MB to 2GB. The binary payload needed by the Ducky is only a few KBs so you dont need a lot of space, unless you using composite firmware (where ducky doubles up as a mass storage device), again this depends on how many binaries or scripts you want to use; but again you only need a few MBs.

Its upto you how you want to proceed.

Snake

Link to comment
Share on other sites

Thank you for a quick reply. I was going crazy over this. I've just tried it on a Linux (SliTux) VM and still no luck. I'm in the UK so P&P alone rules out getting a replacement from the HakShop. I don't fancy forking out another $40 in P&P. :P I don't have any spare MicroSD cards, but I'll have to try any blag one from University or something. At the moment, I have almost $90 worth of USB shaped brick. It's sitting right next to my Raspberry Pi shaped brick as well. :'(

If I ever get a "Hello World" script running then I will probably end up putting the TwinDuck firmware on it. I've got some really nice C#.NET payloads which I'd like to test out; including one that I've dubbed "FireFox Extinguisher".

If I were to test it with my 32GB MicroSD, what method should I use to format it? I assume it's FAT32.

Edited by ApacheTech
Link to comment
Share on other sites

Just a note, if anyone else has this problem. The MicroSD card itself was extremely difficult to remove from the Duck in which it came packaged. In the end, I had to get a jewellers flat-headed screwdriver to lift up the thin metal locking pin. When the MicroSD finally came away from its housing, there was an audible snap, as of something giving way. I assumed the worst for a moment, but I've checked the Duck with a continuity tester and everything's fine. There was, however, a gold circular sticker, with a plastic peelable cover on the underside of the SD card. My assumption then was that, during transit - or even during initial shipping from the factory - the label became humid and temporarily fused to the casing of the SD socket. I'm unsure as to what after-market service the ducks have to go through, now that they're sold en-masse.

If there is a level of after-market service they have to go through, I would suggest shipping the SD card within the card reader, rather than within the duck itself.

Edited by ApacheTech
Link to comment
Share on other sites

UPDATE:

The USB-RD works perfectly with a 32GB MicroSD. FireFox Extinguisher v0.0.1 Alpha is now working. :-D Now, onwards and upwards to create the ultimate USB (Yumi) Multiboot Utility Key with the TwinDuck Firmware.

"Oh don't worry,it's meant to do that, there's a ton of diagnostics programs on there, it's just configuring itself for your system."

Which, in essence, it could do. But, in reality, I'm uploading their Firefox profiles to my FTP site.

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...