Jump to content

The art of not deauthing yourself


Zephyr
 Share

Recommended Posts

Ok, with wifi jammer, and all my mac's in the whitelist, it seems I'm still deauthing myself.

Here's my setup:

The pineapple is connected to my laptop as normal via PoE ethernet and is being powered by the brick. It's working fine as an AP.

I have my Alfa card connected as usual and functioning, and it is connected to some open, internet-enabled AP somewhere. (My Alfa card is not connected through the pineapple, but rather directly to my laptob via usb cable).

My pineapple firmware is 2.7.7 and wifi jammer is v2.9.

Ok so I have entered all my macs into the whitelist, yet when I run the jammer, both of my devices (an Android and a second laptop) connected to my pineapple AP are still getting deauthed. More weird, whenever I run the jammer, right after everything gets deauthed, the WLAN light on the pineapple starts to continuously flash in a steady fashion, almost seeming to denote an "error." At this point the pineapple is not operating as an AP. There is no signal, as seen by either my second laptop or the Android.

The only way to get everything working again is to reboot the pineapple. Then everything's fine. Both my Android and second laptop connect to the pineapple again and they're both happy. I'm still experimenting but not discovering much of a fix at this juncture. If anyone might have a suggestion please feel free to jump in.

Link to comment
Share on other sites

Hey Mr Protocol, In the whitelist tab it reads: Note: APs on the whitelist are not DeAuth'ed.

And there is a default [grep] expression in the blacklist box of:

# Every AP
[a-zA-Z0-9]*

along with an admonishment below of: Note: APs on the blacklist are DeAuth'ed.

But in the rare event that things might have been reversed, and on your suggestion, I tried reversing things and put all my macs in the blacklist. Same result. Everything gets deauthed, the pineapple's WLAN light flashes, and I have to do a pineapple reboot.

By the way, all of this is towards the goal of being able to sit down near a target area and deauth APs and clients without deauthing myself, naturally ;)

EDIT: Addition information. I noticed that in the WiFi Jammer drop down list, it is only giving me the option to use interface wlan0, the pineapple itself. - wlan1, which if I'm not mistaken should be the Alfa card, does not show up in the drop down list. For the sake of elimination I disconnectd the Alfa altogether a re-ran the experiment. Same result. In other words, Wifi jammer has been using the pineapple's radio as apposed to using the Alfa to send the deauths. Correct me if I'm wrong but I'm pretty sure the opposite should be true. It should show wlan1 (Alfa) and wlan1 (Alfa) should be doing the deauthing.

Edited by Zephyr
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...