Jump to content

[BugReport] Error "Failed to write File" to RubberDucky sdcard


09Sparky
 Share

Recommended Posts

Hello,

For some reason I cannot write to my new RubberDucky on the SD card. I get an error "Failed to write hex file"

I believe I followed all the steps and started with the most basic program "hello world"


REM Description: Hello World!
STRING Hello World
ENTER

then I downloaded the duckencoder.jar to a folder. Inside that folder I now have duckencoder.jar and hello world.txt

Then I type the command: (done as root/su) "java -jar duckencoder.jar -i helloworld.txt -o /media/USB/inject.bin


Then I get the error "Failed to write file"

Additionally, I have tried it in 3 (linux) computers now and keep getting Input/output errors.

I tried inserting another standard sdcard (one I had laying around), but it didn't work. It was recognized and allowed me to copy the inject.bin file, but once I transfered the card over to the device it did nothing. Now, I am new to the rubberducky and not sure if a new card can work, as it probably has special software installed, but if now than please advise also.

Thanks,

sparky

Link to comment
Share on other sites

Nope.

Can you provide screen dumps of the following commands:

  • dmesg
  • mount
  • [how the error is generated]

Can you also use spoiler tags, to make the page more readable when you provide these logs.

Thanks

Edited by midnitesnake
Link to comment
Share on other sites

I actually just packaged it back up and sent it back for a replacement. I didn't want to mess around too much trying to fix a brand new product, as I imagine it should work out of the box. Once I get the new rubberducky, if I have the same issue (than its most likely me) I will report the output of those commands. Thank you very much for your assistance!

Link to comment
Share on other sites

Well, I returned the first devices and received the second. It worked for awhile. At least it accepted code and I got green lights. however, after a few successful executions it went bad also. however, it looks like just the sdcard went bad. I tried formatting it, but it doesn't even seem to get recognized on my windows pc. I inserted a spare 2gb card (formatted fat) and it works. it seems odd to have two bad cards, etc in a row. Is there any way to fix this or is it trashed?

Output From the bad card:


dmesg output:
[369376.185133] usb 1-1.1: new high-speed USB device number 16 using ehci_hcd
[369376.278228] scsi19 : usb-storage 1-1.1:1.0


mount output:

proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /home/XXXXXX/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=XXXXXXXXX)

Edited by midnitesnake
Link to comment
Share on other sites

Rest assured that the Ducky now sounds fine as you've seen red & green lights.

Im not sure whats going on with the sdcards? Maybe their a cheaper brand of cant stand the current cold weather? Sounds like duff sdcard if your other 2GB sdcard works.

Ive seen micro sdcards for under $3 http://www.amazon.com/512MB-Sandisk-MicroSD-TransFlash-Memory/dp/B000JI5K94/ref=sr_1_sc_1?ie=UTF8&qid=1360566811&sr=8-1-spell&keywords=micro+sdcard+512mb, might be worth the extra small investment.

Maybe we should start a list of cards that are reliable, and cards that appear to break down often?

Edit:

If the sdcard is recognised on linux you should have a /dev/sd*, but be careful as hard-drives have a similar assignment. You can normally confirm the assignment from dmesg log output.

Incase your not aware mkfs.vfat (or mkdosfs -F 32 depending on distro (package dosfstools)) can format fat32 volumes on linux.

Edited by midnitesnake
Link to comment
Share on other sites

Yeah, my sd card is toast. Actually inserting it into the usb converter and leaving it in more than a few minutes gets extremely hot to the touch (almost fire hazard hot). Linux doesn't appear to recognize the card at all.

It may not be a bad idea to start a list of reliable cards, but It may just be coincidence/bad luck on my part. My 2Gb SanDisk MicroSD card still appears to be working well. I don't know what the brand is that comes with the USB Rubber Ducky other than Micro SD 256MB.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...