Jump to content

Recommended Posts

  • Pineapple Hardware Version Mark IV
  • Pineapple Software Version (ex: 2.5.0, 2.6.4): How do you tell without being able to connect to it?
  • OS used to connect to the pineapple: OS X 10.8.2
  • 2008 MacBook
  • Model Identifier: MacBook5,1
  • Processor Name: Intel Core 2 Duo
  • Processor Speed: 2.4 GHz
  • Memory: 4 GB

Network layout of how your setup is connected (including IP information):>>

Macbook is connected to Airport Timcapsule via wifi

Macbook ip address


I am currently running Backtrack 5v3 and Windows 8 on parallels version 8.

I have tried to connect via both the above softwares. I followed the instructions in the booklet that came with the pineapple.

In the instructions for the windows 7 it states that you will see Pineapple facing adapter I do not see this in my list. I only have two option in my network adapters one is ethernet connections and one is the wifi connections. I do however see the pineapple listed in my wireless connections under wifi connections. I have tried to connect to but was not prompted for user id and password. Also when I plug the pineapple into the ethernet connection on the windows systems it shows it connected but again I cannot connect to it.

In backtrack when I run the wget script I am able to download the software and install it. I can run wp4.sh and it asks me for the setup I hit all the defaults and am prompted to click the link to connect to the pineapple in a internet browser but that is far as I can get >>

Pineapple Network []:

Pineapple Netwrok []:

Interface Between PC and Pineapple [eth0]:

Interface between PC and Internet [wlan]:

Internet Gateway []:

IP address of Host PC []:

IP address of Pineapple [];

Internet - wlan0


Pineapple - eth0

SIOCDELRT: No such process<<< I am concerned about these two errors

SIOCADDRT: No such device<<<

When I try to connect to the link listed I get Firefox cannot establish connection

Parallels current settings under the device> network >wi fi bridged

Under virtual machine >configure >security> I did not choose isolate machine. I have read multiple post where people are saying they choose this option. I have taken it off and put it on. I have also tried to bridge multiple connections with no luck. I have been unsuccesful trying to communicate with the pineapple. When I establish a wif connection via windows I can see the wireless activity light.

I have tried unpluggin the ethernet cable from the WLAN to the PPOE as well. I am pobably trying to set to many diverse settings at the same time.

Internet Gateway where would I find this setting? Where would I find this information? Anyway any help would be appreciated.


Link to comment
Share on other sites

1) I am not a mac user but maybe this topic will help you connect to your pineapple through OS X :http://forums.hak5.org/index.php?/topic/27808-mac-ics-works/

2) Are you able to connect wirelles to your pineapple? If so navigate to: (i guess pineapples are still shipping with an old firmware version or if you running 2.6.4 or above)

3) As you can read at the Wifi Pineapple Book at the: "Ethernet to PC" connect your pineapple to your pc through PoE/LAN port.

4) From a quick search i found this topic where a user had the same problem (output) with the wp4.sh script: http://forums.hak5.org/index.php?/topic/28157-issues-with-wp4sh-in-linux-mint/ just try to run the script as root

I hope i have helped you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...