Jump to content

Help! Wps Flashing


Recommended Posts

Hello, I play with the pineapple during 1 week whithout any problem, but yesterday I upgraded the firmware 2.4.0, I load all the modules to the USB partition. I changed de language to spanish.

The pineapple was ok. Perfect, I executed de sslstrip module, and 2 hours later, perhaps, I turn off de power. When I try to turn on, the pineapple only show the led blue "pwr" on. I can´t login to webui like before. I try to press de reset button... after 10 seconds, the others blue leds are on, but i can´t login.

I try to switch-off switch-on the power, and the WPS is flashing continuosly after now. I try several times to switch-off-on, but always, the WPS is flashing every 0.5 seconds... I have unpluged the LAN, the usb pendridve, the ethernet.

If i try to press de reset, the pineapple don´t respond,

I don´t know how to do. Sorry for my bad english.

It´s time to do a clean flash, using the post of Mr-Protocol? How I can open the box ? I need some USB/Serial to UART cable?

Another possibilty to try?


Link to comment
Share on other sites

Have you tried removing the flash stick from the usb and then booting? Also (if not already) use the wall wart to power the pineapple instead of the portable battery. If all else fails, do a clean flash. You can open it by removing the two screws under the rubber feet. It should be on the side where the usb is at. Get the USB to UART cable but make sure it has 3.3v.

Link to comment
Share on other sites


Thank you for all recommendations.

Unfortunattelly, the pineaple is in the same state. I removed the flash stick from the usb. I removing the two screews, and now the box is open (Thanks BigFanOhak5)

i don´t understant the expression: "setting up ICS", I try to configure de connection using the script wp4.sh, but the ssh to pineapple don´t respond. Also don´t respond to ping.

Now I need a converter USB-UART, is dificult to find in a local town, probably i search some in ebay... Any recommendation?

Thanks for this great forum, It's my favorite place in internet. Until I repair the pineapple, I will learn more about it...

Link to comment
Share on other sites

"Setting up ICS" means Internet connection sharing through your OS (ie Windows, Mac, Linux). As for the usb-uart adapter I use, I bought it off Ebay. It took about a week in a half to arrive because it was coming from China, but I can vouch that it works. Here is the link:


Link to comment
Share on other sites

I suggested setting up internet connection shareing because in the past I have almost bricked my mk4, what worked was having ICS and pressing the reset button for 10 seconds, then I was able to log into ssh and perform an manual upgrade, I can't remember If I had to reboot the pineapple or not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...