Jump to content

OpenVPN NAT Problem


Sparda
 Share

Recommended Posts

ok, so I setup a OpenVPN server (sucsesfuly) clients can connect, however, having followed the section about router all trafic (including web traffic) and implimenting it, any connected client can nolonger access the Internet at all.

This is the IP configuration the clients get:

IP Address: 10.8.0.6

Subnet: 255.255.255.252

Default Gateway 10.8.0.5

DNS Server: 10.8.0.1

I'm not sure where to begin with fixing this problem. The subnet set in the configuration file is 255.255.255.0, but I'm not sure if thats the problem. The default gateway of the clients also appears to be wrong, I would have expected that to be 10.8.0.1. Any one have any ideas? The following is all active server configuration options:

port 1194

proto udp

dev tun

ca /etc/openvpn/keys/ca.crt

cert /etc/openvpn/keys/server.crt

key /etc/openvpn/keys/server.key

dh /etc/openvpn/keys/dh1024.pem

server 10.8.0.0 255.255.255.0

ifconfig-pool-persist ipp.txt

keepalive 10 120

comp-lzo

user nobody

group nobody

persist-key

persist-tun

status openvpn-status.log

verb 3

push "redirect-gateway def1"

push "dhcp-option DNS 10.8.0.1"

Link to comment
Share on other sites

  • 8 months later...

Hey Sparda, did you ever figure this out? Looks like you followed the same tutorial as me. It's been a minute since I've messed with it, but your config file you posted is that the config file for the server and clients? Or just one of the 2?

Link to comment
Share on other sites

@ Sparda... I forgot your basically strictly Ubuntu:) I was trying to get it working on w2k3 and XP. I haven't messed with it for awhile, but I may give it a go this weekend.

@ requiemnoise, nice find on the forums. Looks like alot of useful info. Thanks:)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...