Jump to content

Linuxmint 10 Ics


Recommended Posts

At home I want to connect my Jasager with my HP laptop that runs LinuxMint 10.

If I enable ICS on my NIC in Linux it will setup a network 10.42.43.1 while ICS under WindowsXP will create 192.168.0.1

If I Google it looks like you can not change 10.42.43 to 192.168.0, correct? - is there a work around for this that anybody knows?

If not can I then 'simply' setup the Jasager with 10.42.43.250 and will internet on all client connected to the Jasager then work as well?

Thanks for your answer.

Cloggie

Link to comment
Share on other sites

  • 2 weeks later...

Do the ICS from the command line using brctl from bridge utilities. Google for full info but the basic idea is

brctl addbr br0 - Create a bridge

brclt addif br0 eth0 - add the wired interface to the bridge

brctl addif br0 eth1 - add the other interface, change these to appropriate interfaces.

ifconfig eth0 0.0.0.0 up

ifconfig eth1 0.0.0.0 up - clear the IPs

ifconfig br0 up - bring up the bridge

That should enable bridging.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...