Jump to content

Jasager & Dhcpd Setup


Recommended Posts

Hi I have been scouring the forums, and I cant seem to solve this issue. I have a FON 2100 that I have flashed with

Jasager firmware 1.0. I was able to install x-wrt r4838.

Now I have the FON2100 plugged into a router where there is a dhcp server that gives out the ip to the LAN port of the 2100. I enabled dnsmasq on the FON, but I dont see any ips ever assigned to the SSIDs that I see in Jasager. I see the KARMA messages about associating ssid. I want the FON to handle dhcpd and allow clients to connect it. I am planning on using wireshark plugged into the same hub to monitor traffic flowing in and out of the FON 2100.

dnsmasq is running.

/usr/sbin/dnsmasq -K -D -y -Z -b -E -s lan -S /lan/ -

Where is the forum post outlining how to enable dhcpd. Or if someone can put out config info on dhcpd and how to enable it please let me know.

Thanks in advance

Link to comment
Share on other sites

You might have to manually edit a file to have the interfaces (wireless and wired) on the FON become a virtual hub. That is what i had to do to get the packets forwarding through.

Also, why not hook up the fon directly to the computer you want to monitor with and do ICS/Forwarding so you don't have to use a hub.

Please reference this install guide.

Look for the stuff under "functions.rb" on that post. That is the same thing I had to do and made my own notes before that was all posted.

http://www.hak5.org/forums/index.php?showtopic=15269

Last steps of Part 2

Link to comment
Share on other sites

Thanks for the info -

I made the changes - but I still dont see any ips being assigned out through the wireless access point.

The main reason I am not hooking up the FON to a pc is that, I figured I have a router upstream, that can pass the traffic to the FON device. Also my pc only has one network port so I have that plugged into the same router.

I made the changes to functions.rb. I see that dnsmasq is running, but how can I verify DNS is working on the wireless side. Thanks

Link to comment
Share on other sites

My setup I have the fon via crossover cable plugged into my laptop ethernet port. And i connect my laptop to wireless.

I have a static IP on the Fon and Laptop ethernet port.

Did you setup your gateway properly on the setup?

SSH into the Fon. Accept the host key, and log in as root with your new password. First, you need to enable the wireless. The following commands will do this:

uci set wireless.wifi0.disabled=0 
uci commit wireless && wifi

Next, pick an IP range and IP Address for the Fon. I chose to use one on the private range 172.16-32.X.Y range, because my home network is on the 10. range, and a couple of places I want to demo it at use 192.168.

Execute the following commands to do as I did, and set the Fon to 172.20.0.2:

uci set network.lan.ipaddr=172.20.0.2
uci set network.lan.gateway=172.20.0.1
uci set network.lan.dns=10.10.0.1
uci commit network

(10.10.0.1 is my home router)

Also configure dnsmasq to give out the gateway IP and DNS servers. In /etc/config/dhcp, under the section config dhcp lan, add:

        list 'dhcp_option'      '3,172.20.0.1'
        list 'dhcp_option'      '6,10.10.0.1'

Reboot the fon (The command via ssh is 'reboot'). Change your IP to be on the Fon’s range, then SSH into its new IP address. Accept the host key.

Edited by Mr-Protocol
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...