Jump to content

Deft


jnt
 Share

Recommended Posts

Has anyone tried or used DEFT? It can be downloaded at deftlinux.org It claims to gear itself towards law enforcement.

Seems pretty good, still playing with it, but cant quite get it to boot off the multiboot usb as an iso, or unpacked.

Link to comment
Share on other sites

So this seems to be the most successful entry as far ...

title DEFT v5
find --set-root /deftv5x.iso
map /deftv5x.iso (0xff)
map --hook
root (0xff)
kernel /casper/vmlinuz file=/cdrom/preseed/xubuntu.seed boot=casper iso-scan/filename=/deftv5x.iso splash
locale=en.UTF-8 --
initrd /casper/initrd.lz

deftv5x.iso is on the root of my usb

It boots to an xdisplay, you see it going through boot scripts, then mentions searching for devices, and goes to a blank screen, then hangs. changing terminals doesnt work or anything to see what type of boot messages im getting.

So, I also tried using the 'cli.seed' in place of the xubuntu, and the same boot up happens except this time it drops to a prompt (as i hoped). It drops down to the initramfs prompt. Error is basically saying it can't find deftv5x.iso, and mentions not being able to locate a 'live enviroment'.

Another thing im noticing is that it appears to be looking for it on 'sdb', however most every live distro i boot, usually utilizes 'sdc'. Is it possible that the boot is not finding the usb drive when it comes time to mounting the filesystem?

Edited by jnt
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...