Jump to content

Jasager v2 BlackList


tcas
 Share

Recommended Posts

Noob user here so just like to say hi.

I have come late to the fon and jasager, but after weeks lot's of learning it's up a running. However there is one problem I can't solve without help, everytime I try to blacklist my own ap either via the web interface or even adding it via /etc/karma, it does not hold and keeps poping back again, like a dodgy kebab.

Is it something I am not getting or is it a bug is jasager. Any help would be welcome please.

Link to comment
Share on other sites

After 3+ hours of playing I've managed to set my build environment up again to work on Jasager. So far I've managed to build the same broken package as is already installed but at least it is a start!

Now I've got it on my main dev machine though I should be able to work on it much easier than trying to piece bits together on my laptop which is where it was before.

Link to comment
Share on other sites

After 3+ hours of playing I've managed to set my build environment up again to work on Jasager. So far I've managed to build the same broken package as is already installed but at least it is a start!

Now I've got it on my main dev machine though I should be able to work on it much easier than trying to piece bits together on my laptop which is where it was before.

Thanx for your hard work. Once a couple of small bugs are ironed out this will be an awsome tool of mass destruction.

Link to comment
Share on other sites

Just done another couple of hours. Fixed a problem where the module would just seg fault the kernel and force a reboot whenever it was loaded. That is an old bug that I'd fixed in the past and reported to the maintainers but forgotten to back port.

For some reason it just doesn't like the extra ioctl of addkarmassid. I'm playing with stripping it out and putting it in bits at a time to see if that helps.

Link to comment
Share on other sites

I think I've fixed it. Got a kernel module that builds and the command works fine. Not tested that it actually does its job yet but I'm optimistic about that bit.

The only problem is I've got it working for the 8.09.1 OpenWrt release rather than 8.09 that my current firmware is built on so I'll have to do you all a new firmware.

Its 2.35AM here so going to back everything up multiple times and call it a night. Will try to find time to build the firmware tomorrow.

Anyone running Jasager on an 8.09.1 firmware (you can tell by running uname -a and looking for kernel version 2.6.26.8) who wants the package early just drop me a PM or email and I'll send it over, the ipk file is sat here so doesn't need any extra work.

Link to comment
Share on other sites

There is nothing to be tested unfortunately, the testing is me building the package, transferring it to the fon and installing it, rebooting the fon then starting up the interface and watching what happens. It was seg faulting and locking it up as soon as the module was loaded, now it faults and reboots as soon as the interface comes up.

I just need another evening to sort it out but as the last one started about 9PM and finished at 3.30AM I've got to pick a day when I can afford a lie in in the morning.

If there are any coders out there who want to try to debug it I'm happy to pass the almost working patch over along with build instructions.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...