Jump to content

Help With Tunneling Through DNS


xANTIx
 Share

Recommended Posts

So I've been trying to set up my computers so that I can tunnel ssh dns to get past the pay to acces wifi points. But I ran in to a little trouble. I got MIMI-Base32 installed, and Net-DNS, and I have OzymanDNS and everything. I think I have it set up right on my home box. But when I try to run Ozyman on my laptop I get this,

Can't locate MIME/Base32.pm in @INC (@INC contains: /Library/Perl/Updates/5.8.8 /System/Library/Perl/5.8.8/darwin-thread-multi-2level /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-thread-multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /Applications/OzymanDNS/droute.pl line 8.

BEGIN failed--compilation aborted at /Applications/OzymanDNS/droute.pl line 8.

ssh_exchange_identification: Connection closed by remote host

My laptop is running OSX btw, and my desktop is running linux.

Any help would be much appreciated. Thanks.

Link to comment
Share on other sites

  • 2 months later...
  • 7 months later...

I just hit the same problem. I installed MIME::Base32 through ports which worked, checked with CPAN and it agreed it was installed but dnstunnelc still failed to find it.

So, I downloaded the package from the CPAN site. Search for the package in CPAN then check top right of the page for download link I think.

Manually unpacked and built the module then copied the .pm file into the directory with dnstunnelc in it. You then need to make a change to dnstunnelc as the generic function call to encode doesn't exist any more. I can't remember off the top of my head but if you look in the .pm file for encode there are two functions, choose the one that is RFC compliant. Change the encode function in dnstunnelc to call the new encode rather than the old and it should all start working.

I'm surprised no one else has hit this problem before, or at least reported it.

Link to comment
Share on other sites

  • 2 years later...
  • 2 weeks later...

I know of the best and simplest solution to this problem. Uninstal OSX and install a Linux based os that comes pre-loaded with more netowrking tools, such as Backtrack. While you will still need to download a couple modules, your overall experience will be better and there will be more people who can help you out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...