Jump to content

redboot.pl does not connect to new Fon+


Mat
 Share

Recommended Posts

Ok, so my Fon+ finally arrived and I set about installing interceptor, so I boot ubuntu, set the wired ethernet port to 192.168.1.254 using:

ifconfig eth0 192.168.1.254 up

which seems fine, then I run redboot.pl with:

./redboot.pl 192.168.1.1

and that's as far as I can get, the ping is never acknowledged so the script never moves onto the telnet, I've tried telnetting manually but of course that does not work.

What am I doing wrong here, I must be missing something basic.

Link to comment
Share on other sites

I repeated the process a few times with no results. From reading about it would seem that the Fon will only respond to a telnet request for a very small time, and it seems that the pinging is to find that window and trigger telnet as soon as the fon is ready.

I think the problem I'm having is linked to the ethernet connection on the laptop taking longer to connect to the router than the router does to boot up.

Is this likely?

Link to comment
Share on other sites

First question, what country are you two in? The UK versions of the basic Fons I've seen have their redboot set to listen on 0.0.0.0 which basically means you can't get into them through redboot, it may be the same with the fon+.

Just to check you are doing things in the right order, you need to start up redboot and then power on the fon. By default the fon waits 2 or 4 seconds (can't remeber which) and I've always managed to get redboot straight away.

Link to comment
Share on other sites

I'm in the UK. I have tried it by running redboot.pl and then powering the fon but it still does not connect.

I did try powering the fon and then the computer, to let the computer dhcp from the fon, this way the fon had an IP of 192.168.10.1 and the laptop was given 192.168.10.103.

If the fon is 'listening' on 0.0.0.0 then is there a way to reflash these units or did I just waste 30 quid?

Link to comment
Share on other sites

redboot only listens for 2 seconds on initial power on so letting the fon boot definitely won't work, you have to hit it straight way when you plug the power in.

Just as a test, put eth0 on 192.168.1.254 and then ping 192.168.1.1 and power on the fon. See if you get replies, you should get 4 replies then it will stop. If you don't then it isn't listening.

As ssh is open by default on the fon+ you could use the mtd method of flashing, I haven't done it but have a search for it as there was someone else in the forum asking about it. Alternatively make a cable for under a tenner and access it that way, much more fun and a guaranteed entry into the fon regardless of what you mess up.

Link to comment
Share on other sites

Isnt that test the same as the method you describe here: ? http://www.digininja.org/interceptor/install_walkthrough.php

No, here I'm suggesting just using ping to see if you get a reply, that is how to do the actual flash. If you get a response from the ping then it is reboot.pl that is failing, if you don't then the fon isn't listening on the IP address. Or your machine isn't on the IP address you think it is, see below.

I;ll try it again on a machine that's not running the ubuntu network manager and see if that helps, I doubt it will though.

I'd kill anything like that before even thinking about doing something like this. That network manager is evil! Also kill any dhcp clients you have running, probably dhclient or dhclient3 so try killall dhclient to remove them.

Yes. It looks similar the method Darren describes in his write up on flashing for Jasager.

Link to comment
Share on other sites

Well I just tried again with a CentOS box that does not have a GUI, I set the IP and ran ping and powered the fon and got nothing.

I now have the fon connected to a laptop and I'm trying the other method but that also seems to fail. I made and opened the two html files, but the errors shown in the writeup do not appear and the ssh port is not opened.

This fon has a firmware of 3.1.1 r1, if that's of any help to anyone.

Well digininja, thanks for your help, it looks like I'll be building a serial cable. I think I have a max232 chip around somewhere from when I built myself a nokia datacable many years back, I assume it's a similar process?

Link to comment
Share on other sites

I don't know about that specific chip but building a cable is definitely the way to go, you get direct access to the fon and it makes life just so much easier. You can fully play with all the networking stuff and not lock yourself out.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...