Jump to content

Unbricking Fonera ---- hanged after flashing


Recommended Posts

Hi,

My fonera was bricked a couple days ago and was suggested my many people to use a serial cable to unbrick it. So I made a serial cable my self with Max232 chip and a couple caps. I was able to load openwrt-atheros-2.6-rootfs.squashfs and openwrt-atheros-2.6-vmlinux.lzma files on to fonera. Here is fis dump

RedBoot> fis list

Name FLASH addr Mem addr Length Entry point

RedBoot 0xA8000000 0xA8000000 0x00030000 0x00000000

vmlinux.bin.l7 0xA8030000 0x80041000 0x000C0000 0x80041000

rootfs 0xA80F0000 0x80041000 0x006F0000 0x00000000

FIS directory 0xA87E0000 0xA87E0000 0x0000F000 0x00000000

RedBoot config 0xA87EF000 0xA87EF000 0x00001000 0x00000000

Now it wasn't able to load Openwrt after its restarted. I tried a couple different ways and none of them worked.

here is the hyperterminal dump

PHY ID is 0022:5521

Ethernet eth0: MAC address 00:18:xx:xx:xx:xx

IP: 192.168.1.254/255.255.255.0, Gateway: 0.0.0.0

Default server: 0.0.0.0

RedBoot bootstrap and debug environment [ROMRAM]

Non-certified release, version v1.3.0 - built 16:57:58, Aug 7 2006

Copyright © 2000, 2001, 2002, 2003, 2004 Red Hat, Inc.

Board: ap51

RAM: 0x80000000-0x81000000, [0x80040450-0x80fe1000] available

FLASH: 0xa8000000 - 0xa87f0000, 128 blocks of 0x00010000 bytes each.

== Executing boot script in 10.000 seconds - enter ^C to abort

RedBoot> fis load -l vmlinux.bin.l7

Image loaded from 0x80041000-0x80290085

RedBoot> exec

Now booting linux kernel:

Base address 0x80030000 Entry 0x80041000

Cmdline :

it just hangs after that, I waited for a couple hours and nothing seem to work. Any suggestions please??

Link to comment
Share on other sites

Made it to work. It was the problem with the serial connection Baud rate. I changed this console baudrate from 9600 (default) to 115200 so that kernel and filesystem files can be quickly transferred to fonera through the serial cable.

PM me if some one needs help here.

Link to comment
Share on other sites

I didn't know you could transfer the files across the serial cable. How did you do it?

Redboot by default is capable of transferring the files over tftp, http, xmodem and ymodem protocols. My fonera is not detected by my computer when I connected with an ethernet cable. You can transfer using either xmodem or ymodem protocol to transfer using a serial cable, the later is faster. I used a trail version of SecureCRT.

This is how you do it.

1.first we have to start the xmodem server on redboot,

load -r -v -b {FREEMEMLO} -m ymodem

This will tell RedBoot that a file is being sent over ymodem

2. send the file you wish to transfer by using "ymodem" option under "Transfer" menu

This should do it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...