Jump to content

ICS problems


tux_
 Share

Recommended Posts

I have been trying to set up ICS in doze for my fon.

I have tried every method i could think of, then came on here and trawled through every piece of information concerning it, then tried it, to no avail.

After over a week, ICS is still not up.

I have this currently set up:

Connected fon to laptop via ethernet

Connected laptop to my private ddwrt firmware'd wrt54gs via a wg511T card

Set my wireless as shared.

Set wireless ip to static and to 192.168.1.139 with dns of 192.168.1.1 (ive tried with virgin media's dns, and opendns both not working)

Set ethernet to static at ip 192.168.0.1, with no default gateway and no dns servers entered

In my cgi-bin/webif/netowrk.sh i have done this:

Type Bridged

IP: 192.168.0.250

Default gateway: 192.168.0.1

LAN DNS server: 192.168.0.1

What in the above is incorrect?

I have come to the above results through thousands (literally) of logical combinations. I know how tcp/ip functions etc but this one has me totally stumped.

If someone could point out the errors, that'd be awesome.

Link to comment
Share on other sites

ok from what it looks like, youre trying to share your netgear cards internet connection to the fon right? what youre doing wrong is setting all these statics, you shouldnt need to manually set the ips or dns server addys. so when your wireless card is connected to the wrt its will have some local ip of 192.168.1.100 for ex. now when you go into "my netork connections" and go to the properties of your netgear card youll see the "advanced" tab and in there is where you check the "allow other network users to connect through this connection" then you have to pick which interface you want to share your internet to. in this case it would be your local area connection or ethernet card, then right under that youll see another settings tab this is where you have to tell ICS which network features you want internet users to be able to use you need to check off DHCP DNS UPnP, etc. see when you enable ICS windows will set your ethernet connection automatically to 192.168.0.1 and if you dont enable the DHCP and DNS settings for it to use then it wont properly addressany device you plug into your ethernet port. also in the "general" tab of your wireless cards properties youll see interenet protocol TCP/IP check box. highlight it and check the properties of it. it should be set to obtain IPaddress automatically, and obtain DNS servers automatically. you dont need to manually set any of these. the last thing you should check is any software firewall youre running. you may need to tell it that your computer is now a gateway server running NAT, otherwise its gonna fuck with all the arp packets trying to get through. then thats it.

also dont bridge any of the connections.

Link to comment
Share on other sites

  • 1 month later...

Hey,

It sounds like its not a matter of bridging connections but allowing the wireless to share its internet with Ethernet. I have set this up but i am still locked out of the fon. the fons ip: 192.168.1.1 is not accessable especially when the internet connection is shared. matter of fact there is not even a defult gateway when i check the status of my Ethernet connection. I heard i might need to change some ip's. I have no clue how to do this. Any ideas?

Micah C

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...