Jump to content

hipapheralkus

Active Members
  • Content Count

    6
  • Joined

  • Last visited

About hipapheralkus

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I was thinking that being able to use ALT + ASCII codes could create a truly universal keyboard language layout. I think that numeric keys and ALT character should be universal for any keyboard layout, and by leveraging this, all the special characters, as well as normal letters could be inserted by their ASCII codes. Taken, it would require ~4 "keystrokes" per character so it might be slightly slower, but it would be a very good trade-off between the speed and functionality - being able to use a single language for any keyboard layout. Does anyone know if this is possible for the ducky? Or could it be implemented in some new firmware version?
  2. Thanks a lot:) It seems that I made 2 or 3 mistakes: when typing payload.txt, I should have used double-quotes, e.g. QUACK STRING "My super \"payload\" | everything works" As stated in the us.json file, the only 2 characters requiring escaping are backslash and double-quote, as long as I write everything into double quotes it seems that changes in .json files are not properly taken, until I safely remove my Bunny USB, which caused me plenty of trial-and-error why it doesn't work and final change was moving "CTRL-ALT":"05,00,00", a bit more upwards, so that all keys using CTRL+ALT are properly (not sure if this step was necessary though) I've just created Pull request from Czech and Slovak json language files, and they work for me on machines I tried:)
  3. can I ask where did you have problem which you then solved? I want to connect my PC to VPN using login+password, but something is failing and I don't know what. I've updated Squirrel to 1.1; copied config.ovpn to /root/payloads/switch3/config.ovpn; added "auth-user-pass login.txt", created /root/payloads/switch3/login.txt with username password updated payload.sh to the newest https://github.com/hak5/packetsquirrel-payloads/blob/master/payloads/library/remote-access/openvpn/payload.sh and made 1 modification: FOR_CLIENTS=1 so that the PC connects to VPN over the internet. I connect PC to ethernet-in; router to ethernet-out, change payload to 3, unplug+plug USB power; and after a while I see yellow led blinking once which should indicate the connection is established, but in reality I don't have the new IP address when I check what's my IP (I'm connected online though). Can someone please help me? Many thanks
  4. I want to create a couple of new keyboard layouts for the community. I downloaded USBlyzer, so that I could observe the key codes for all the keys on my keyboard. On Czech keyboard, some special characters need "special attention". For example, pipe character is not present, unless I press "leftCtrl+leftAlt+w". Once I do that, I can see the code in USBlyzer: 05 00 1a 00 00 00 00 00 So far so good. I went to /languages/us.json, made a copy, named it cz.json, and changed pipe line accordingly: "|":"05,00,1a" Then I created this simple payload.txt to see if it is pressed (I have Czech layout turned on) ATTACKMODE HID STORAGE DUCKY_LANG cz QUACK STRING bla\|aa When I tried this, I can only see "blaaa" string being shown, no pipe character is present. Note that when I change DUCK_LANG to "us" it works and writes pipe character as expected. Am I missing something, or Bash Bunny has some issues with running these commands?
  5. There are some keyboard layouts, which don't have special characters (e.g. Slovak or Czech) like pipe or backslash. Since such characters can't be single-pressed on keyboard, I was thinking about writing inside the QUACK file.txt file some specific code with ALT encoding, .e.g STRING command1 ALT 124 STRING command2 which would simply be written as command1 | command2 Unfortunately, I'm unable to write such ALT 124 key combination. Is this approach possible with Bash Bunny?
  6. I've read through all posts but I'm still unable to connect my bash bunny online:( I have Windows 10; I disabled my firewall and network protection, I set up network sharing; set IP address of Bash Bunny adapter to 172.16.64.64. and mask to 255.255.255.0 (all the other fields, like default gateway and both DNS servers are empty). When I go to putty and SSH to 172.16.64.1 I'm able to connect. From Bash Bunny, I'm able to ping 172.16.64.64 successfully, but nothing further on the way. My wifi internet adapter in Windows has following setup: IPv4 Address. . . . . . . . . . . : 192.168.0.18 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : 192.168.0.1 My BashBunny adapter: Ethernet adapter BashBunny: Connection-specific DNS Suffix . : IPv4 Address. . . . . . . . . . . : 172.16.64.64 Subnet Mask . . . . . . . . . . . : 255.255.255.0 Default Gateway . . . . . . . . . : As you can see, the Default gateway is not assigned which might probably be the reason I'm unable to connect anywhere from Bash Bunny. When I try to ping 8.8.8.8, 192.168.0.18 or 192.168.0.1 I'm not successful, the only success is the ping 172.16.64.64. The setup of ifconfig on BashBunny is following: usb0 Link encap:Ethernet HWaddr 5a:00:00:5a:5a:00 inet addr:172.16.64.1 Bcast:172.16.64.255 Mask:255.255.255.0 Can you please help me in making it work? I'm out of options... Thank you all
×
×
  • Create New...