Jump to content

Wifi pineapple mark VII firmware upload error

Recommended Posts

Getting firmware flash error fork/exec/Usr/bin/splitweb: cannot allocate memory 

I've tried from oldest firmware to the newest and keep getting that after each factory reset I try a different firmware and still the same sucks to have such a awesome piece of pentesting tool that now acts like paper weight anyone that's had this and found a solution that can help me? I'd appreciate it alot thank you 

Link to comment
Share on other sites

After doing a factory reset/firmware recovery (according to the procedure described in the documentation), download the latest upgrade file from the Hak5 downloads web site and verify its SHA256 checksum, then:

scp the upgrade to your pineapples /tmp directory
ssh into the pineapple and enter the /tmp directory
(verifying the sha256sum locally on the Pineapple as well isn't a bad idea, just to be sure)
Execute: splitweb /tmp/upgrade.bin (or whatever firmware filename that has been downloaded)
Then run: sysupgrade -n /tmp/upgrade.bin

You do the above at your own risk. I'd suggest submitting a support ticket if you want to get official assistance on what to do.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...