Jump to content

Go to solution Solved by dark_pyrro,

Recommended Posts


Hi everyone,

I'm looking to get a little help in connecting my devices to cloudc2 because NONE of them are connecting. I so far have tried every single possible solution I found on this forum but nothing is working.

I've been running my c2 server on windows and kali using the following commands:

c2-3.3.0_amd64_windows.exe -hostname localhost -listenport 80
c2-3.3.0_amd64_linux -hostname localhost -listenport 80

The cloud UI itself runs smoothly and I can login. I tried adding my Shark Jack, Lan Turtle, Packet Squirrel, and Pineapple VII by downloading the relevant device.config file and transferring it to the devices using:

scp device.config root@172.16.X.1:/etc/

NONE of them connected to the C2 server. I tried invoking C2CONNECT and C2DISCONNECT on all of them and still NONE of them connected. I deleted device.config and C2.config from each them re-downloaded new device.config files and repeated the process but still NONE of them connected. (I already made sure they are all connected to the internet by SSHing directly into each one and pinging google.com).

Then I tried deleting c2.db and regenerating the tokens and setting up C2 again (on both windows and linux) and repeating the process but still NONE of them connected.

Any idea what's going on?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...