Jump to content

Amazon C2 connection problems

Go to solution Solved by mandovera,

Recommended Posts

Long story short.

I deployed the c2 on the amazon lightsail.

Had my issues while setting it up like the issue I have been struggling with most was after I started up the service I could access the website only when I had the ssh window running.

I set up the start on boot and running systemctl status and it is running with no errors

The issue I have is that now I cannot access the website at all.

I sticked as close to the deployment docs changing only the necessary IP adresses.

any ideas what I could do?

Link to comment
Share on other sites

  • Solution

Ok, I figured it out eventually. While I did the initial setup " https://docs.hak5.org/cloud-c2/guides/enabling-cloud-c-as-a-service-on-boot-and-exfiltration" from this link I was had to change the service file because of a typo, after I was already finished with the whole setup. The service status was running with errors. I fixed it and the service status appeared online and did not show any errors, but I could not connect to the web api. The solution to this was to redo the last sequence of restarting daemons and enabling,starting cloudc2.service with systemctl commands. Now it works smoothly so I hope if anyone has the same issue this could help. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...