Jump to content

How to only press ALT ? - Rubber Ducky

Go to solution Solved by entombed,

Recommended Posts

Hello - I have an older USB Rubber Ducky. I need to press only the ALT key. I’ve tried INJECT_MOD ALT but it doesn’t seem to work, and actually somehow opens Office 365 on my test Windows laptop. Any ideas?

The goal is to open a task manager, press ALT and then press F so that I can open the file menu, and then start explorer.exe manually.

Target is a windows kiosk without explorer.exe running, so key combos like WIN+R don’t work even if I plug in a keyboard.

End goal is to open powershell and ultimately automate a reverse shell/kiosk escape combo with the ducky, and everything works so far minus getting the ducky to automate pressing the ALT button with nothing else.

I’m using the web-based encoder. I tried an older jar encoder with no luck, in fact the option to only press a modifier key didn’t seem to exist. Any suggestions would be very much appreciated.

Link to comment
Share on other sites

  • Solution
8 hours ago, dark_pyrro said:

It's a lot easier if you post the payload code so other can try to recreate what you're experiencing and troubleshoot from there

I included the relevant code in my post, it’s literally just INJECT_MOD ALT - that wasn’t working at all in the web encoder. I’m escaping a Windows 10 kiosk using very hyper-specific inputs for specific applications so nobody can recreate anything except ALT, as it was the only issue I was having with the encoder.
By testing only ALT, it would strangely press WIN(GUI), CTRL, SHIFT, ALT at the same time. Using multiple keyboard testers reported it was pressing the Meta key lol.

I was able to bypass this by using a java encoder (2.6.3) and used ALT F7 in my code. Not ideal, but it worked for some reason. Seems like an encoder issue. Elsewhere online it seems like people have been having trouble with ALT combinations. Something to look into for whoever maintains the encoders.

Link to comment
Share on other sites

The Java encoder isn't supported anymore, so it will not be looked into. Not the old HTML/Javascript based encoder either. PayloadStudio is the only supported encoder/compiler.

INJECT_MOD isn't a part of DS 1.0 so it will simply not work on the 1st gen Ducky, you'll need the 2nd gen Ducky/DS 3.0 for that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...