Jump to content

AWS Lightsail VPS (Ubuntu) not able to wget or curl C2 stable version for setup

Go to solution Solved by dark_pyrro,

Recommended Posts

Tried the download with curl and got 66 bytes on the c2.zip output. I cat'd the file and it showed
{"error_message":"cloudc2 firmware version -stable not found"}

Are the instructions on the C2 quickstart guide (that I posted a picture of above) correct in the URL that I should be grabbing from?

Also tried wget.. debug output:

ubuntu@ip-172-26-0-28:~$ sudo wget --debug https://downloads.hak5.org/api/devices/cloudc2/firmwares/ -O c2.zipSetting --output-document (outputdocument) to c2.zipDEBUG output created by Wget 1.21.2 on linux-gnu.Reading HSTS entries from /root/.wget-hstsURI encoding = ‘UTF-8’--2023-09-08 19:07:48-- https://downloads.hak5.org/api/devices/cloudc2/firmwares/%E2%80%8BResolving downloads.hak5.org (downloads.hak5.org)... 2607:f8b0:4004:c17::79, downloads.hak5.org => 2607:f8b0:4004:c17::79 to downloads.hak5.org (downloads.hak5.org)|2607:f8b0:4004:c17::79|:443... connected.Created socket 4.Releasing 0x00005626383944b0 (new refcount 1).Initiating SSL handshake.Handshake successful; connected socket 4 to SSL handle 0x0000562638395ae0certificate: subject: CN=downloads.hak5.org issuer: CN=GTS CA 1D4,O=Google Trust Services LLC,C=USX509 certificate successfully verified and matches host downloads.hak5.org---request begin---GET /api/devices/cloudc2/firmwares/%E2%80%8B HTTP/1.1Host: downloads.hak5.orgUser-Agent: Wget/1.21.2Accept: */*Accept-Encoding: identityConnection: Keep-Alive---request end---HTTP request sent, awaiting response... ---response begin---HTTP/1.1 404 Not FoundContent-Type: text/plain; charset=utf-8Vary: Accept-EncodingX-Content-Type-Options: nosniffX-Cloud-Trace-Context: 36c6bac8d241b64410ea63a1c5afe71a;o=1Date: Fri, 08 Sep 2023 19:07:48 GMTServer: Google FrontendContent-Length: 66---response end---404 Not FoundRegistered socket 4 for persistent reuse.URI content encoding = ‘utf-8’Skipping 66 bytes of body: [{"error_message":"cloudc2 firmware version -stable not found"}] done.2023-09-08 19:07:48 ERROR 404: Not Found.[Needn't fallback to non-utf8 for ‘https://downloads.hak5.org/api/devices/cloudc2/firmwares/’ubuntu@ip-172-26-0-28:~$ lltotal 36drwxr-x--- 4 ubuntu ubuntu 4096 Sep 8 19:07 ./drwxr-xr-x 3 root root 4096 Sep 3 12:15 ../-rw------- 1 ubuntu ubuntu 4253 Sep 8 19:06 .bash_history-rw-r--r-- 1 ubuntu ubuntu 220 Jan 6 2022 .bash_logout-rw-r--r-- 1 ubuntu ubuntu 3771 Jan 6 2022 .bashrcdrwx------ 2 ubuntu ubuntu 4096 Sep 3 12:18 .cache/-rw-r--r-- 1 ubuntu ubuntu 807 Jan 6 2022 .profiledrwx------ 2 ubuntu ubuntu 4096 Sep 3 12:15 .ssh/-rw-r--r-- 1 ubuntu ubuntu 0 Sep 3 12:22 .sudo_as_admin_successful-rw-r--r-- 1 root root 0 Sep 8 19:07 c2.zip
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...