Jump to content

Issues connecting to Wireless on Keycroc


Recommended Posts

Hi All

I having issues on my keycroc - that I actually never have been online in the year I got it.
I having a running C2 cloud - but this single device is the only one that I'm missing here.

Firmware is version: 1.3_513
I know regarding the special char like this - \@\!\! --which I've done as expected - but no matter what -it'll not connecting to the Wifi.
Logging in to my keycroc through screen when in armoured mode :

# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether f2:fa:26:b5:05:cb brd ff:ff:ff:ff:ff:ff
3: tunl0: <NOARP> mtu 1480 qdisc noop state DOWN group default 
    link/ipip brd
4: gre0: <NOARP> mtu 1476 qdisc noop state DOWN group default 
    link/gre brd
5: sit0: <NOARP> mtu 1480 qdisc noop state DOWN group default 
    link/sit brd
6: ip6tnl0: <NOARP> mtu 1452 qdisc noop state DOWN group default 
    link/tunnel6 :: brd ::
7: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DORMANT group default qlen 1000
    link/ether 68:b9:d3:06:69:cc brd ff:ff:ff:ff:ff:ff

And if I'm starting using the file directly  /etc/wpa_supplicant.conf  - it'll still not change anything here - only getting in logfile this repeatly:

Mar 15 04:36:52 croc kernel: [  417.216087] RTW: wlan0 sleep m0=0x00000002, ori reg_0x4d4=0x00000000
Mar 15 04:36:54 croc kernel: [  418.886917] RTW: wlan0 wakeup m0=0x00000002, ori reg_0x4d4=0x00000002
Mar 15 04:36:54 croc kernel: [  418.887153] RTW: survey done event(4) band:0 for wlan0
Mar 15 04:36:54 croc kernel: [  418.887301] RTW: rtw_indicate_scan_done(wlan0)
Mar 15 04:36:54 croc kernel: [  418.903839] RTW: cfg80211_rtw_scan(wlan0)
Mar 15 04:36:54 croc kernel: [  418.903903] RTW: rtw_cfg80211_set_probe_req_wpsp2pie(wlan0) listen channel - country:XX, class:81, ch:1

But no matter what it'll show my network Interface as DORMAT.
And I'm Quite sure that its the rigth password - since its the same I've connected all other devices to ( 3G mobile Router)

wlan0: Trying to associate with 20:54:fa:4b:53:02 (SSID='XXXXXXXXXXXXXX' freq=2427 MHz)
wlan0: Associated with 20:54:fa:4b:53:02
wlan0: CTRL-EVENT-DISCONNECTED bssid=20:54:fa:4b:53:02 reason=0 locally_generated=1
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="XXXXXXXXXXXXXX" auth_failures=4 duration=77 reason=CONN_FAILED
wlan0: CTRL-EVENT-DISCONNECTED bssid=20:54:fa:4b:53:02 reason=3 locally_generated=1

And not sure where to go from here. Think I've tried everything - Reset the device many times - but have never been online with my settings,  So Ok - Then I changed the Wifi to be my existing home Wireless - and here it's working So I'm guessing it have something to do with my Password here.
But since its a little special - the Chars are then here = @ !

And I typing the password with the \ (backslash) in front of each of those above special Chars - but it will not connect as long as the special chars are in the password.

Any Ideas - (Yes I know I can change the Wifi Password to fit - But I would like not to - since other devices are attached to the existing )


Link to comment
Share on other sites

Is the network (that is not working) a hidden network? Doesn't seem to be the actual issue since there are auth_failures in the output. If you disable the WiFi related parameters in the config file of the Croc and enter the passphrase as it should look like (without backslashes to escape chars) in /etc/wpa_supplicant.conf, does it work?

Link to comment
Share on other sites

I made a script for the Croc specifically a while ago that you could use when trying to troubleshoot the WiFi issues. Not really needed, but can be handy.

I use it in the way the readme says, i.e. have different WiFi "profiles" stored as files on the Croc and then being able to connect to the desired AP when needed.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...