Jump to content

Updated Correctly but no WIFI Connection (INVISIBLE SIGNAL OWL?)


Frittle
 Share

Recommended Posts

I've followed the guides and can get the Signal Owl into arming mode (with double LED blink) updated to 1.0.1 with the proper scripts and directories, however I can't get a WIFI connection or SSH connection.

 

I have a USB formatted to FAT32

it has a folder named extensions containing a WIFI_CONNECT.sh file:

#!/bin/bash
#
# Title: WIFI_CONNECT


function WIFI_CONNECT() {
    logger running extension: wifi_connect
    ifconfig wlan0 up;sleep 2
    echo -e "network={\nssid=\"$WIFI_SSID\"\npsk=\"$WIFI_PASS\"\npriority=1\n}">/tmp/wpa.conf
    wpa_supplicant -B -Dn180211 -i wlan0 -c /tmp/wpa.conf
    while(iwconfig wlan0 | grep Not-Associated); do sleep 1; done
    udhcpc -i wlan0
}
export -f WIFI_CONNECT

#

then outside the folder is the payload.txt file(in my script I put my WIFI creds which contain no special characters, only letters and numbers):

#!/bin/bash
WIFI_SSID="ssid"
WIFI_PASS="pw"

LED SETUP
WIFI_CONNECT
/etc/init.d/sshd start
LED SPECIAL2

#

 

Am I doing something wrong? I ran chmod 777 on both the payload.txt file and the wifi_connect.sh file. I tried pinging the IP its supposed to automatically be at[172.16.56.1 is what I have], nothing. Finally I ran nmap thru the entire 172.0.0.1/8 range because I wanted to be thorough(on my closed network where the signal owl should be) and found nothing (while the signal owl is plugged in and blinking like its in arming mode). As far as I know I've done everything correct and am in arming mode with no payload or firmware errors but no ssh or wifi or ability to ping/nmap. 😕 Any help would be appreciated!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...