Jump to content

Problems Setting up FreeNAS


Jeffrey Ropp
 Share

Recommended Posts

First off, thanks for the show guys. Very entertaining and informative.

I recently watched episode Episode 2x02 and decided to give FreeNAS a shot. I have zero LINUX experience, but figured the setup looked easy enough.

My old PC recognizes the CF card:

Primary IDE Master [LEXMAR ATA FLASH- (PM)]

Type = Auto

Maximum Capacity = 82MB

Multi-Sector Transfers = [Disabled]

LBA Mode Control = [Disabled]

Transfer Mode = [Fast PIO 4 ]

Ultra DMA = [Disabled]

But....

During the boot from CD I noticed:

ad0: FAILURE - SETFEATURES SET TRANSFER MODE status=51<READY,DSC,ERROR> error=4<ABORTED>

After the installation, I get simply "Read error".

After reading everything on the FreeNAS forums, I tried modifying the loader.conf file to include a line to force LINUX to disable DMA to agree with BIOS:

hw.ata.ata_dma="0"

No dice.

Any thoughts? The CF was pulled from a working camera. The adapter is new. I'm stuck.

What PC/BIOS did you guys use in your demo?

Any help is greatly appreciated.

Cheers,

Jeff

A few specs:

Dell XPS Pentium III - running at 1.4GHz

640 MB RAM

Lexar 80MB Compact Flash connected via ID Adapter

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...