Jump to content

Nano via Mac: Yes LED, No Dashboard & Internet sharing


bajaXXBlast
 Share

Recommended Posts

I have a brand new Nano which I am trying to setup for the first time. I was able to get to the dashboard at one point. But I couldn't get the bulletins to show up.. I'm on a Mac with the latest OS. Can internet connection sharing be done on a Mac to the Nano? I haven't see this online. What I have tried is below... but at the end of all this, I clicked shutdown on the dashboard... I got the normal pop up message.. and was unable to connect to the dashboard anymore.. But the LED wouldn't turn off. So I waited a while then unplugged the device. I tried plugging it in > no dashboard, timeout error trying to connect. So i hard reset the device and it rebooted. Still nothing, but the led blinks when booting and goes solid after that with a little flickering representing the wifi connectivity like normal. What should I do ??? 

Here are the steps I tried when my dashboard was working in order to get internet connectivity sharing going on my Mac: 

1. wp6 -- I tried downloading the wp6.sh script for Linux on the website to smoothen the connecting process from Mac to pineapple. But Mac doesn’t have iptables and that might be the reason for the error I get which is on Step 3 it won’t find the device. I installed iproute2mac. It tells me to plug in the WiFi Pineapple “Please connect the WiFi Pineapple to this computer” and waits till it sees the MAC address for it.. but shows me the searching dots and never actually finds the device for some reason even though it does exist when I type in the part after "until pineappleiface=$" command from wp6.sh manually WITHOUT the

 | grep 'eth\|en'

part. However, the IP address does show up in ifconfig so I know it’s plugged in... oh and I can see the dashboard and the Ethernet connection so I know it’s plugged in.

2. Youtube Tutorial -- I also tried doing it manually via a YouTube setup video (the only one I’ve found for Mac https://youtu.be/m7XUmfC8ESw ) which had me go to my network settings for Mac > Ethernet > DHCP to Manually > type in 172.16.14.42 > make my subnet 255 and so on > then add a DNS 8.8.8.8. Then it had me go to Sharing in System Preferences and turn it on from my WiFi for Ethernet which I did do for USB, and both Ethernet options just in case. Still nothing, in fact this is when I started to not see the dashboard until I fiddled it’s the IP address a bit... So turns out when I turn off internet sharing on my Mac, I am able to connect to the pineapple dashboard, but when I turn internet sharing on, I am not able to. Strange. I had no problem getting to the dashboard when internet sharing is off, when I tried to load the bulletin I got: Error connecting to WiFiPineapple.com. Please check your connection. The error message when turning on Internet Sharing is on: HTTP Error. Then when I go to reload the page, I can't even load the dashboard.

3. Virtual Machine -- So I see that windows and linux have working steps, I set up a ubuntu virtual machine and ran the wp6 script... it could not find the wifi pineapple, same error “Please connect the WiFi Pineapple to this computer” - the dots kept coming and I had to Ctrl+C. When i type in ip addr, I don't think it sees the device IP. So I setup windows 10 in Virtual box and I can access the dashboard. But I don't see the AXIS ethernet in connected adapters. I add it to the devices in the device list and RESTART the pineapple because it still wasn't showing up in the connected adapters.

 

At this point, the device wouldn't shut down its LED even though the dashboard went inactive. So I tried hard resetting, like I mentioned in the first paragraph, but I'm still at the same place as before: Dashboard won't show up, but LEDs showed it rebooted, then after the hard reset they react normally like nothing happened. After that I still need to solve wifi connectivity... I will try the device list addition again in windows to see if it will show up, and then Kali Linux. Is there a method for internet connection sharing on Mac ?? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...