Jump to content

Cloud C2 on Android?


Recommended Posts

Hello peoples,

Has anyone had any luck running C2 successfully on Android?
I am able to execute program and have a proper login GUI. But i keep getting "error invalid license key"

Which makes no sense to me since I am using a new download from hak5 website. So I do get a new token and license key upon download. But no successful login. C2 runs beautifully on my laptop

 

I am using termux to execute On One plus7 pro. With nethunters (non rooted)

Link to post
Share on other sites
  • 1 year later...

I didn't see any other posts on this topic, so here's what worked for me and hopefully for anyone else reading this

So I'm using VIVAX Fly V550 (android 5.1) (I know, quite an old phone, but good for small local servers)
Termux by itself got the same error, so I remembered you can install a linux distro on termux and that's what got it working

I used Andronix since it worked for me before and it's just a copy paste process
After installing Andronix, I installed debian, downloaded and unzipped C2 and then I ran the appropriate binary (c2-3.1.2_armv8_linux)
The installation went fine and I was able to use it without any problems
And of course, as any lazy person would do, I made a script to automate the start process with the help of google

./c2-3.1.2_armv8_linux --hostname $(ip -4 addr show wlan0 | grep -oP '(?<=inet\s)\d+(\.\d+){3}')



Notes:
The phone is rooted, but I don't think that should make a difference
I only tried the debian distro since it worked off the bat and I didn't bother testing others
It takes a considerable amount of time to install the distro and I had to install a few basic packages, I didn't track how much space it takes

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...