Jump to content

Some very strange behaviors from my owl...


tecno
 Share

Recommended Posts

Hello fellow signal owl owners...

In my earlier post named "SUCCESS! a few simple but effective tips" I outlined how I got my owl to reliably connect to an open network 100% of the time. While that is still true and working, my Signal Owl has started acting very strange and I wanted to share.  In the post I mentioned above, I mentioned it is a good idea to start simple and build upon your working script.  Well, I took my own advice and tried to add WPA encrypted network support to my owl and failed.  Thats not the strange part though, the strange part came when I went to revert to the basic connect script that was just working fine and I lose the ability to SSH in. so here is what happened...

 

1. copied the known working script to connect to open networks to the owl through the open AP the owl generates at 172.16.56.1

2. rebooted the owl and it connected to my open network like it should , the IP assigned is 192.168.1.57, I verified it was so in my router.  

3. I try to ssh in and it tells me the host is down, or it just hangs and times out

4. I check to see the payload has the line

/etc/init.d/sshd start

which it does.  This was just working before I tried to connect to a WPA network with the hak5 GitHub script WIFI_CONNECT

5. So I write a little debug line and put it into the script right after the line that starts up the ssh daemon, it looks like this

/etc/init.d/sshd start

ps -A | grep ssh >/root/loot/debug.txt

LED CLEANUP

 

6. I reboot and the file is there but empty, no output, but the LED is blinking cleanup so the script got to the end and completed all steps.  Why won't sshd start up now?  I run the startup command for the ssh daemon manually on the command line and check the process list its there, running, so the command works.  Now I'm at a loss, the command works but the script will not run it...now what?

7. Next step, reload  firmware... right?  WRONG!  I put the firmware file on the USB Drive, install it into the correct port on the owl, boot the owl, hit the button during selection mode and ........it starts the open AP and never does the upgrade.  I've done it 4 times and each time it goes right into the AP mode complete with double blinking LED and all.  I can even connect to it and ssh in like usual through 172.16.56.1.  curiouser  and curiouser...

 

I think it is the lazy techs crutch to blame hardware for a perplexing problem, but in this case.... I am out of ideas and I wonder if any of you are having the same weird issues.  Im still reluctant to blame hardware because the behavior is consistent, it is just consistently wrong and odd.  Thoughts anyone?

 

Thanks 

tecno

 

Link to comment
Share on other sites

I got to do a little more testing today and I further discovered that my owl is no longer interacting with the USB port at all.  If I press the button while the payload is running, it does not copy any onformation to the USB stick.  I can not do a firmware upgrade either, it skips right over the firmware loading sequence and if a script calls for an extension, the owl isn't sourcing the extensions directory.  At this point I am sure it is malfunctioning though I don't know if it is software or hardware at this point.  If there was a way to reset the device, I could explore further, but at this point I believe I have reached the end of the line.

 

To test if you are having problems wit the Signal Owl interacting with the USB storage you can...

1. Place a payload.txt file on the root directory of a USB flash drive and insert it into the "hot" USB port on the owl.  When you boot the owl, the payload file should be copied over automatically and overwrite the existing file if one already exists.

2. Place a file in the /root/loot/ directory on the owl, then reboot.  At some point, after the payload is running, press the button once.  This should copy the contents of the /root/loot/ directory to the USB Drive.  

3. if the above both fail, you could try to flash the firmware as  as detailed on the hak5 docs page, but only as a last resort.

 

If any of these steps fail to work properly or in my case, all three do not work, then I can say with confidence the device is not working as intended.

 

tecno

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...