Jump to content

Execution permissions with Bash Bunny


Recommended Posts

I'm trying to run LaZagne (Linux) on the bash bunny for a Linux payload. LaZagne works by itself when I run it on my Linux system, but once I copy it into the bunny under payloads, it says permission denied. I went to properties and tried to tick the "allow the execution of this file" tick box, but it just unticks itself right away. I tried "chmod +x" it changed it for a brief second then reverts back to un-executable. Anyone else run into similar issues?


EDIT: I'm not having issues running windows .exe, just Linux binary files it seems

Edited by Am3ience
Link to comment
Share on other sites

follow up question, is there anyway to SSH into the bunny to where the payloads are located? I can SSH, but i'm having a hard time finding where the payloads are stored. I was thinking of just chmod +x the LaZagne file while SSH in to see if that would fix it.


Link to comment
Share on other sites

Hi @Am3ience,

according your first question: Could you give us more information. Which distro are you using and can you give us the output of "ls -l" of the bunny folder after you copied it there. 

According the second question: You should find the payloads (when sshed in)  under /root/udisk/payloads


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...