Jump to content

Payloads not working?


Recommended Posts


I've been using my packet squirrel for about 2 weeks now and it's worked great. I can capture packets like nobody's business and VPN out to my VPS in the cloud without any issue. I upgraded the firmware to 1.2 and shortly after, I decided to try some new modules. I've tried the following and they all have behave the same way:


In every case my host machine indicates there is no cable plugged in and I get no activity on the packet squirrel LED  after the boot sequence (I know ngrep is stealthy intentionally, but the button doesn't flash red or green either). These modules also don't write anything to USB (which is formatted correctly, even reformatted to ext4 from the squirrel). While the tcpdump module works just fine every time. I did go through the readme.md files and tried to change the network mode etc... just to get a different result. No luck. I'm sure I'm doing something wrong. I've re-downloaded the payloads and reflashed the squirrel as well.

Any help is greatly appreciated! 

Link to comment
Share on other sites

  • 5 weeks later...

Hey guys, I have an update on this! 

I got a little frustrated and ended up only using the squirrel for basic packet captures (which was still great to have). But it left me empty inside knowing it can do so much more. Finally I had another go at figuring out this payload situation. I tried to run the scripts manually to see the CLI output/errors and it was a simple permission issue. I had to grant execute permission to all for each payload.sh before it would do anything. 

I'm still a Linux noob. So if there was something I could have done to avoid this in the first place, or anything I can do now to avoid modifying the individual file permissions each time I swap out a payload.sh please enlighten me!


Link to comment
Share on other sites

  • 2 years later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...