Jump to content
Hak5 Forums
Sign in to follow this  
factgasm

Mk5 Client Mode - no interfaces?

Recommended Posts

Posted (edited)

Mk5 using firmware version 2.4.0.

Did a remote deploy last night. Pineapple was taped up with gaffer tape to protect it from the weather, so no sockets or plugs were exposed whatsoever. We had a torrential thunder storm about two hours after deployment. Got it home this morning, dried off the few drops on it. Opened the pineapple casing - it was bone dry inside. I was able to connect to it from my phone, and from my laptop I could shell in and WinSCP in too, but something didn't seem right about it.

Did a factory reset. All four lights, green,yellow, blue, red flashed. Good. Then went to do some basic set up.

Went into the Network tile, clicked Client Mode and clicked on the dropdown box next to Interface. There were no interfaces showing and have not been showing since. Please help.

I have followed the suggestions on this thread. Shelling in and running the cat /etc/config/wireless from the command line showed no reference to radio1 at all, however an ifconfig shows reference to wlan0 and wlan0-1.

PS I have just run iwlist wlan0 scanning and iwlist wlan0-1 scanning and both are picking up the ESSID for my home wifi so it appears both radios survived the weather but still no interfaces showing on the Client Mode tab of the Network tile. Please help!

Edited by factgasm
Additional comments.

Share this post


Link to post
Share on other sites
Posted (edited)

Seriously would appreciate some help on this.

In Recon mode the Pineapple picks up the ESSID for my home wifi but still no interfaces showing on the Client Mode tab of the Network tile. Please help!

Edited by factgasm

Share this post


Link to post
Share on other sites
Posted (edited)

I have just upgraded to 3.0.0.

It's a lovely lovely new look, it must be said.

However still no interfaces showing on the Interface dropdown box of the Wifi Client Mode section. Please help!

Is there some command I can issue in the Pineapple's command line I can enter to refresh the interfaces so they show?

It is as if a file containing the list of interfaces has been corrupted, but I don't know which file. Please help!

Edited by factgasm

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×