Jump to content

so... when did luci webadmin break?


pr0metheus
 Share

Recommended Posts

hi all, so about 2 years ago i decided to turn my mk5 into a plain ole regular openwrt router. though it may seem like sacrelege to amany amongst you,
i thought it was pretty dope. i retained many of the pineapple infusions in the background using nginx but used uhttpd for the webadmin.

installing it was as simple as:

opkg update && opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

anyway, that was about two years ago. as one of the antennas broke, it just sat in a box collecting dust since then. however, this week, after finally fixing the damn thing, i decided to reflash and start from scratch. but alias! the luci webserver is broken. no more luci interface:

i just keep getting this:

Unable to launch the requested CGI program:
/www/cgi-bin/luci: No such file or directory

 

 

anyone familiar with this? i have quite literally been alternating firmware versions — from the latest, down, then from the earliest up. i must've tried in excess of 10 firmware installs by now.
then, when i tracked down the date of the build to mid-2014, i fanned out from there... nothing.

i just know that the solution is as simple as a few lines of code — any takers?

jah bless

Link to comment
Share on other sites

wooh! finally fixed it. for those who may be interested in doing likewise, the process is as follows:

flash the latest beta firmware version 3.0.0, open /etc/opkg.conf and append the following lines:
 

src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages
src/gz base http://downloads.openwrt.org/snapshots/trunk/ar71xx/base/
src/gz luci https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/luci/
src/gz management https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/management/
src/gz packages https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/

 

then execute the following:

opkg update
opkg install luci

 

this also installs uhttpd. by default, it binds HTTP to port 80 which i believe will conflict with nginx. to modify, edit /etc/config/uhttpd and modify like so.

    # HTTP listen addresses, multiple allowed
        list listen_http        0.0.0.0:1234

then it's a matter of enabling the uhttpd startup and service with
 

/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start

you will then be able to login to the luci admin page, in the above example, at 172.16.42.1:1234

 

 

 

 

Edited by pr0metheus
corrected opkg file path
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...