Jump to content

ifconfig wrong network


lilfear1
 Share

Recommended Posts

PLEASE HELP!!!!

The other day I was playing with my wifi pineapple mk5...I was attempting dnsspoof...I had everything working just fine...until the index.html that Darren's tutorial on youtube caught me...I didn't know how to create that...I now know.

 

Today I went in to play with it again now that I know how to create the index.html, which I have created (yes its a basic hello world).

My problem is that no matter what I do I cannot get on the internet at all from my Kali box, AND when I go into network to add in client mode my target network it does fine UNTIL I exit that page and click the "internet IP: show" then it says error connecting.  I go back into the network, client mode, I have even disabled the current network and re-scanned, and re-entered the correct target network. Still same error.

 

NOW, I ifconfig and it shows that my wlan0 is the 172.16.42.xxx network and not my home network, with wifi turned on and even with my rj45 unplugged from the pineapple.  I have tried to connect to google.com and I get "problem loading page" which I am not sure if is better than the one I was getting before that was telling me my proxy won't let me access site (this is when I am no logged into root for some reason) When logged into root I don't get proxy error anymore just that I cannot connect.

 

I am sorry for the ramble but I am seriously lost.  My background, I have my AS in computer networking and security, and I help teach IT classes at the local library.

I am new to linux and well I remember playing with backtrack 5 then when everything went to kali it well I finally got a kali box to work...well sorta hehe

ok here is an overview of what I have said:

logged into root

pineapple unplugged from ethernet and ethernet disconnected on kali, Kali only connected to local network but when I ifconfig I get the pineapple network (172.16.42.xxx)

I have even restarted pc, logged out of all users and re-logged in as root

I don't know, every time I try something (hacking wise) NOTHING EVER WORKS RIGHT.

Yes I am very frustrated, I am in my 40's and I really want to learn this but every time I try a tutorial ANYWHERE even off HAK5, even with my Rubber Ducky nothing seems to do as expected.

I don't know shit about coding...well, I am learning (slowly...I make the .html hello world thing) Yea I know, WOW hehe

Can someone please help me figure out wth is going on, and maybe get me on the right track.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...