Jump to content

OpenVPN not working


Recommended Posts

I know the title doesn't describe the problem but it is more complicated than a title...


I was following the OpenVPN tutorial from Hak5 that was posted recently. I followed it VERY closely besides naming my server and client differently. I know my way around Linux though not a pro but here is what I have tried (I tried these all under root just in case).


# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether fa:16:3e:95:61:ab brd ff:ff:ff:ff:ff:ff
    inet SERVERIP/32 brd SERVERIP scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fe95:61ab/64 scope link
       valid_lft forever preferred_lft forever
# ifconfig
eth0      Link encap:Ethernet  HWaddr fa:16:3e:95:61:ab
          inet addr:SERVERIP  Bcast:SERVERIP  Mask:
          inet6 addr: fe80::f816:3eff:fe95:61ab/64 Scope:Link
          RX packets:109196 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90345 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11802396 (11.2 MiB)  TX bytes:13847838 (13.2 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:88 (88.0 B)  TX bytes:88 (88.0 B)
# ufw status
Status: active

To                         Action      From
--                         ------      ----
22                         ALLOW       Anywhere
1194/udp                   ALLOW       Anywhere
# ps aux | grep openvpn
root      7356  0.0  0.0  12664  1544 pts/0    S+   18:46   0:00 grep openvpn
# nmap -sU

Starting Nmap 6.47 ( http://nmap.org ) at 2016-07-19 18:47 EDT
Nmap scan report for localhost (
Host is up (0.000012s latency).
Not shown: 999 closed ports
5353/udp open|filtered zeroconf

Nmap done: 1 IP address (1 host up) scanned in 3.60 seconds
# dmesg | grep openvpn
# service openvpn status
● openvpn.service - OpenVPN service
   Loaded: loaded (/lib/systemd/system/openvpn.service; enabled)
   Active: active (exited) since Mon 2016-07-18 23:02:06 EDT; 19h ago
  Process: 494 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 494 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/openvpn.service


nmap scanning from outside the VPN also doesn't show anything open besides SSH. What I think is wrong is that there is no tun interface.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...