Jump to content

connection error


RuleBreaker1234
 Share

Recommended Posts

I've been having connection problems myself. Is your pineapple connected to the Internet through wifi (wlan1, external nic, etc)? A little more info please.

As for me, I had my pineapple configured the same way for months and it worked really well (although I never got PineAP to work correctly with Dogma).

My Setup:

*wlan0 = Access Point for karma and PineAP.

*wlan1 = For deauthing peeps.

*wlan2 = ALFA AWUS036NEH (from HAK5) as client to connect to internet.

*wlan3 = ALFA AWUS036NHA set as a secondary access point with encryption enabled for a secure connection for using the web interface with my phone.

All of this worked very well for months. Then one day, out of the blue, I noticed I would loose internet on ALL interfaces (even eth0) as soon as a client (me) would connect to wlan0 and start browsing the web. The thing to note here is that I could browse the internet through eth0 no problem. I could CONNECT with my phone to wlan0 and still have internet at eth0, but as soon as I start to BROWSE the internet on wlan0, about 2 seconds later I loose all internet on ALL interfaces (not the web GUI though). Everything looks normal in the system logs.

This problem has been consistent and I went so far as to re-format my SD card and factory reset the Pineapple. Everything works fine when I use wlan1 as the client connecting to internet (besides the re-booting issue and the limited throughput issue) but as soon as I try to use the AWUS036NEH as the client and then try to browse the internet on wlan0 with my phone, BAM! Connection lost.

Generally I try exhausting all of my efforts before I ask on the forums for help, but I saw your post, RuleBreaker1234 and thought I would share what I've been seeing.

Anyone else having similar issues? You may also want to check out THIS post

Edited by WiFi Cowboy
Link to comment
Share on other sites

I cannot access the web interface now. Well, I can access it via ethernet or wlan0, but when I enter the password and push the button, the screen just kind of wiggles and stays there on the front page. I know the password is still correct because I can still SSH in with Putty and the MK5 lets me in.

Only new thing is that I use the new "logs" update that became available yesterday evening. I've tried 5 different browsers on 3 machines (Win7, Kindle Fire and Linux box).Cleared caches, everything.

Weird.

Oh yeah. Need to mention this. The MK5 is working! You can go through it and surf the internets! I did have every thing in the PineAP box running and it seems to be working great. Captured more clients last night than ever before.

I just can't log in as root via 172.16.42.1/1471

Edited by Smart-Aswood
Link to comment
Share on other sites

Pretty sure the Pineapple was doing exactly what it should have been doing. My Kindle was somehow holding a root session open in the background. Turned the Kindle off and back on and problem solved. This is why I don't enter bug reports. It's almost always something having nothing to do at all to the MK5.

The Silk browser on the Kindle Fire handles the MK5 web interface so well too! It loves it so much that it doesn't want to let go of it!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...