Jump to content

Automatic Gain is too much (plain white noise on every frequency otherwise)


Recommended Posts

Hi All,

After testing the rtl_fm command with my new rtl8232u, to ensure the dongle can in-fact tune in to other frequencies...

I've followed the tutorial on creating the FM radio in gnuradio-companion, but no matter what frequency I tune to, the audio, and instrumentation, output is the same, just white noise.

I then read in the documentation that the "Gain Mode" for the source dongle can only be "automatic", by default it's "manual".

When switching to Automatic, the gain is waaaaaaay too high, the sound is distorted, with the waterfall output pretty much solid bright green.

But at least then I can actually tune to different frequencies, so know it's working.

I surely can't be the only one experiencing this, I've checked and double-checked the tutorial to ensure I'm doing everything exactly the same.

Any clues?

Edited by Robsco
Link to comment
Share on other sites

I have found with my RTL that the auto gain is too hot. I normally set the gain manually but I am using SDR# or HDSDR. GNU radio may have similar issues. With no exposure to GNU radio I don't know if you can set it manually but if you can I would try to set it to somewhere around 30db for a start. The other option may be that the waterfall is set to sensitive and may need adjusting as well as the audio gain. I had to play around with SDR# and HDSDR to make the output worth anything. I know this isn't much help but maybe GNU radio is similar. Let me know what you find, sounds like you are close and just need a little tweaking.

Link to comment
Share on other sites

Thanks, yeah I'm nearly there it's a tad frustrating...

The manual option doesn't do anything, that's how I started, by changing the manual gain numbers, to no effect.

I'm wondering/hoping if there's a filter to be applied immediately after the source, to bring the gain down, my fear is tho, that the damage has already been done as the output leaves the source widget in gnuradio.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...