Jump to content

Unable to install infusions to USB partition


koevet
 Share

Recommended Posts

Hello,

I'm struggling to install infusions on the large partition of my 4GB USB drive. Some context:

I have followed Darren's tutorial here.

The swap partition is enabled and working (free shows "Swap: 642748 0 642748")

The fstab file seems correct, according to other posts:

config global automount
       option from_fstab 1
       option anon_mount 1


config global autoswap
       option from_fstab 1
       option anon_swap 1


config mount
       option target   /usb
       option device   /dev/sda1
       option fstype   ext4
       option options  rw,sync
       option enabled  1
       option enabled_fsck 0


config swap
       option device   /dev/sda2
       option enabled  1

The mount command shows some weird stuff:

root@Pineapple:~# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14672k)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)

This is how I install sslstrip (from ssh):

opkg update
opkg install --dest usb sslstrip

and this is the error:

Installing sslstrip (0.7-1) to usb...Downloading http://cloud.wifipineapple.com/packages/sslstrip_0.7-1_ar71xx.ipk.
Installing python (2.7.3-1) to usb...
Collected errors:
 * verify_pkg_installable: Only have 480kb available on filesystem /usb/, pkg python needs 1875
 * opkg_install_cmd: Cannot install package sslstrip.

I have tried with a 4GB USB drive and a 8GB minisd card inserted in a minisd-usb dongle. Same error with both devices.

I'm pretty sure I'm missing something huge here, but I just can't see it.

Thanks

Luciano

Link to comment
Share on other sites

Hey,

I'm replying to myself.

The reason it didn't work is that the partitions weren't formatted as EXT4.

I have used fdisk from my RaspberryPI to partition the usb but forgot to run

mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda2

Everything is working now!

Cheers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...