Jump to content

Ubuntu VPN pptpd network config problem


Recommended Posts

I'm having a problem that has been causing me great distress and I'm putting a 10 dollar paypal bounty on it, 15 dollars for a quick fix (if this is permitted, apologies if it is not).

I want to setup my own VPN server. My server is an Ubuntu 10.04 Server. The VPN server is pptpd.

I want clients of all kinds (Win, Linux, Mac, etc) to be able to connect. Here's the kicker. My server is connected directly to the internet via eth0. There is no router between it and the internet. All the tutorials I've found have been for machines behind routers. All of the tutorials seem to be variants of this one (http://blog.riobard....p-vpn-on-ubuntu)

Setup -

Server: Ubuntu 10.04
eth0 - (this is a public IP facing the internet)
ppp0 -

Client: Windows 7
ppp -
Default Gateway (ppp) -

/etc/pptpd.conf (this is only the important part, let me know if you'd like to see it all) -


IP forwarding/masquerading is enabled on the server.

When the Win7 client connects, the connection succeeds.

The Win7 client can ping and fine while connected. It can ping nothing else, not nor any machines on the range.

My hypothesis is that the Win7 client needs to get (ppp0) as a default gateway to have the proper route. I have found no way to be able to add this to an existing route via the 'route' command, nor have I found a way in any of the config files to do specify the gateway address the client receives.

If you think you might have an idea, please let me know. Thank you hak5, happy holidays.

Edit: here's some bits from the error log.

pppd[10393]: Using interface ppp0
pppd[10393]: Connect: ppp0 <--> /dev/pts/1
pptpd[10392]: GRE: Bad checksum from pppd.
pptpd[10392]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
pppd[10393]: peer from calling number x.x.x.x authorized
pppd[10393]: MPPE 128-bit stateless compression enabled
pppd[10393]: Cannot determine ethernet address for proxy ARP
pppd[10393]: local IP address
pppd[10393]: remote IP address

Edited by simplicity
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...