Jump to content

Problem Mounting Alfa...


Neworld
 Share

Recommended Posts

My new Alfa that came in the mail isn't showing up in iwconfig or airmon-ng..... It does however show up under lsusb

Here's airmon-ng

(see attachment)

iwconfig

(see attachment)

lsusb

(see attachment)

As you can see, my Alfa shows up under lsusb but not under iwconfig or airmon-ng... How do I fix this??

post-40252-0-81146000-1344303219_thumb.j

post-40252-0-88401000-1344303287_thumb.j

post-40252-0-71879600-1344303288_thumb.j

Link to comment
Share on other sites

did you by any chance leave

config swap

option device /dev/sda2

option enabled 1

enabled?

actually i can confirm issue with my new alfa, device functions in bt5r2, wont show via pineapple

Edited by sober
Link to comment
Share on other sites

did you by any chance leave

config swap

option device /dev/sda2

option enabled 1

enabled?

actually i can confirm issue with my new alfa, device functions in bt5r2, wont show via pineapple

sober have you used networkmanager module? if so remove-config under wlan1 and then commiting could fix or a reflash.

Link to comment
Share on other sites

Here is my setup... Take note that the problem arose after using usb hub a while back. Is that possibly what

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

represents?

(see attachment for setup)

post-40252-0-44040500-1344305349_thumb.j

Edited by Neworld
Link to comment
Share on other sites

Here is my setup... Take note that the problem arose after using usb hub a while back. Is that possibly what

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

represents?

(see attachment for setup)

does the alfa show up when plugged directly into the usb port? and from a fresh power up

what I have experienced with my alfa nha is if I use a hub and don't bring up wlan1 "ifconfig wlan1 up" and then issue a reboot the nha does not show up after the reboot "iwconfig"

EDIT:

try the adapter on your computer to see if it functions

Edited by petertfm
Link to comment
Share on other sites

does the alfa show up when plugged directly into the usb port? and from a fresh power up

what I have experienced with my alfa nha is if I use a hub and don't bring up wlan1 "ifconfig wlan1 up" and then issue a reboot the nha does not show up after the reboot "iwconfig"

EDIT:

try the adapter on your computer to see if it functions

Works perfectly on my computer and the Alfa is plugged directly into the pineapple when I posted the pictures above....

I'll try the Alfa through the USB hub to see if it works then.

(update) doesn't work on usb hub either.

Link to comment
Share on other sites

Network Manager radio0 - disabled

radio1 - enabled

was able to get it to show as radio1, committing caused the adapter to power on for a second, then shut back off so far, have issued a ifconfig wlan1 up and rebooted, but not sure that will do anything of much importance.

edit clicking start on the wireless service under these settings causes the adapter to light up for a split second, but never fully goes up and broadcasts

Edited by sober
Link to comment
Share on other sites

Network Manager radio0 - disabled

radio1 - enabled

was able to get it to show as radio1, committing caused the adapter to power on for a second, then shut back off so far, have issued a ifconfig wlan1 up and rebooted, but not sure that will do anything of much importance.

Keep trying... I'm really hoping to avoid a clean flash unless I can do it without the extra parts like the Alfa console board ect.

Link to comment
Share on other sites

figured out how to fix issue, after restart and having radio 1 specified, click to start wireless, go to advanced commands, and issue iwconfig wlan0 up , if you want both adapters to run, then go back, renable radio0, and issue ifconfig wlan1 up, i now have both adapters functioning, be aware the alfa does not light up

wlan0 Link encap:Ethernet HWaddr 00:C0:CA:alfa via usb

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:4 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:32

RX bytes:0 (0.0 B) TX bytes:668 (668.0 B)

wlan1 Link encap:Ethernet HWaddr 00:C0:CA:alfa antenna on pineapple

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:32

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Edited by sober
Link to comment
Share on other sites

figured out how to fix issue, after restart and having radio 1 specified, click to start wireless, go to advanced commands, and issue iwconfig wlan0 up , if you want both adapters to run, then go back, renable radio0, and issue ifconfig wlan1 up, i now have both adapters functioning, be aware the alfa does not light up

wlan0 Link encap:Ethernet HWaddr 00:C0:CA:alfa via usb

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:4 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:32

RX bytes:0 (0.0 B) TX bytes:668 (668.0 B)

wlan1 Link encap:Ethernet HWaddr 00:C0:CA:alfa antenna on pineapple

UP BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:32

RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

sorry still a little confused... can you post the commands you put into putty.

Thanks :D

Link to comment
Share on other sites

Network Manager radio0 - disabled

radio1 - enabled

was able to get it to show as radio1, committing caused the adapter to power on for a second, then shut back off so far, have issued a ifconfig wlan1 up and rebooted, but not sure that will do anything of much importance.

edit clicking start on the wireless service under these settings causes the adapter to light up for a split second, but never fully goes up and broadcasts

I would re-flash looks like things are realy boinked radio0 is internal and if it's messed with.

basicly with networkmanager module when you add wlan1 and say change the setting so radio1/wlan1 is a client, and then decide to disable it with the check box that actually disables radio1 and can no longer work until enabled, removing config and commiting radio1/wlan1 should fix this.

Link to comment
Share on other sites

ah your puttying into the unit i forgot :(

instructions i gave with with the network management module, also peter, they show as radio but when you issue the wlan up commands they reshow as wlan again, im not sure why they do that but was able to get unit to function without a reset.

getting the radio to enable then reputting up wlan makes the radio wlan apparently lol

Edited by sober
Link to comment
Share on other sites

ah your puttying into the unit i forgot :(

instructions i gave with with the network management module, also peter, they show as radio but when you issue the wlan up commands they reshow as wlan again, im not sure why they do that but was able to get unit to function without a reset.

getting the radio to enable then reputting up wlan makes the radio wlan apparently lol

Oh ok.... so your using network management module... I'm still confused on how you disabled radio 0 and enabled radio 1...

If you could be more specific that would be terrific :D

Link to comment
Share on other sites

ok so step 1: plug in alfa adapter

step2: go to pineapple bar

step3: list available infusions

step4:install network manager to internal storage, pin it

step5: open network manager

step6: run auto detect, if that fails to find a radio1 uncheck enable on wlan0 click save, commit, and try again

step7: check enable on radio1, i left radio 0 disabled

step8: advanced settings reboot

step9: on main pannel click connect on wireless, adapter should flash blue for a second

step10: issue command ifconfig wlan0 up and wlan1 up just to be sure

step11: go back in and try to reclick enable wireless if its not enabled, may take a minute to work

step12: run if config and see that your adapters mac is broadcasting as wlan0

step13: open network manager, also enable the other adapter,reboot, go in and ifconfig it up as wlan1

step14: run if config again, now both adapters should be broadcasting

hope it all works out as i seem to have lost the usb i took out to re test everything :D

Edited by sober
Link to comment
Share on other sites

ok so step 1: plug in alfa adapter

step2: go to pineapple bar

step3: list available infusions

step4:install network manager to internal storage, pin it

step5: open network manager

step6: run auto detect, if that fails to find a radio1 uncheck enable on wlan0 click save, commit, and try again

step7: check enable on radio1, i left radio 0 disabled

step8: advanced settings reboot

step9: on main pannel click connect on wireless, adapter should flash blue for a second

step10: issue command ifconfig wlan0 up and wlan1 up just to be sure

step11: go back in and try to reclick enable wireless if its not enabled, may take a minute to work

step12: run if config and see that your adapters mac is broadcasting as wlan0

step13: open network manager, also enable the other adapter,reboot, go in and ifconfig it up as wlan1

step14: run if config again, now both adapters should be broadcasting

hope it all works out as i seem to have lost the usb i took out to re test everything :D

Step 6 fail.... failed to get radio1 :(

will it help if I replace the network config??

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...