Jump to content

Still Cannot Get Ics Working On Windows 7 Mk4 V1.1.1


RichyB
 Share

Recommended Posts

Hi guys, im sure your all very sick of seeing this topic popup from us "newbies" but iv trawled through multiple posts and still haven't managed to get things up and running

here is how i have things setup:

CAT5 cable from laptop into pineapple's POE/LAN port

Set static IPV4 info as below

IP: 172.16.42.42

Sub: 255.255.255.0

Gateway: Blanks

DNS: 8.8.8.8

My laptop is connected to my home WIFI

My wireless card is set to share its connection with LAN card.

my wireless network is on the range of:

192.168.1.1 - Router

192.168.1.3 - Laptop

255.255.255.0

Gateway: 192.168.1.1

Iv tried turning the firewall off in /etc/init.d/firewall but i think its been removed in version 1.1.1 so thats no good.

also tried : echo 1 > /proc/sys/net/ipv4/ip_forward

Still no luck. I connect to the pineapple's ssid pick up a 172.16.42.* address but when browsing no luck.

Hope this is everything it would be good to get a solution sorted in one thread rather than a couple :o)

Edited by RichyB
Link to comment
Share on other sites

Enable ICS on your wifi adapter first and then manually set your IP to 172.16.42.42 on your wired ethernet adapter.

Windows 7 for example will change the ip to a static class C ip when you enable ICS. This could be your problem.

Do you think its anything to do with the fact my WIFI address is a 192.168.1.* address range and the pineapple runs through 172.168.16.* address?

Should they maybe on the same range?

Link to comment
Share on other sites

Nope :)

Even the guide on wifipineapple.com tells you to do the exact same thing.

I've tested it and it does work.

I connected to my wireless network with ip adres 192.168.1.10

Then enable ICS on my wireless adapter and click OK on the warning that a static ip will be set by windows.

I manually set a static ip 172.16.42.42 and 8.8.8.8 dns ip on my wired adapter.

Plugged in a cable from my laptop to the pineapple PoE/LAN port and voila internet on my pineapple and my clients.

Link to comment
Share on other sites

Done everything you have said but just cant seem to get it to work.. When i was looking through that guide it says to select local area connection from the drop down list.. well i dont have a drop down list? Either that or i cant find it

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...