Jump to content

markcoker

Active Members
  • Posts

    70
  • Joined

  • Last visited

Posts posted by markcoker

  1. 
    

    [ 197.860000] eth0: link up (100Mbps/Full duplex)

    [ 197.860000] br-lan: port 1(eth0) entered forwarding state

    [ 197.870000] br-lan: port 1(eth0) entered forwarding state

    [ 199.870000] br-lan: port 1(eth0) entered forwarding state

    [ 201.860000] eth0: link down

    Repeats

    
    

    config interface 'loopback'

    option ifname 'lo'

    option proto 'static'

    option ipaddr '127.0.0.1'

    option netmask '255.0.0.0'

    config interface 'lan'

    option type 'bridge'

    option proto 'static'

    option netmask '255.255.255.0'

    option dns '8.8.8.8'

    option ipaddr '172.16.42.1'

    option gateway '172.16.42.42'

    config interface 'wiredwan'

    option proto 'dhcp'

    option ifname 'eth0'

    # Failed client mode dhcp setting above (current settings)

    # My attempt at static below (its been a while but i believe it should work but it doesnt)

    # option proto 'static'

    # option netmask '255.255.255.0'

    # option dns '8.8.8.8'

    # option ipaddr '192.168.1.200'

    # option gateway '192.168.1.1'

    config interface 'wan'

    option proto 'dhcp'

  2. other devices are getting dhcp assigned addresses, i haven't tried another router but i currently think its unlikely that it will be the router. cable seems fine, I've tested it.

    i have factory reset pineapple, I believe i have all the correct settings, i don't believe there is much required to be set on the pineapple correct? for "normal setup" in client mode.

  3. So i have a fresh install, default settings. I changed wired to client mode (DHCP).

    My understanding this should work but it is unable to access the internet, no ip address is received (eth0).

    Router(DHCP Enabled, standard setup other devices work. IP: 192.168.1.1) <-----> WifiPineapple (default settings except now in client mode).

    any ideas or hints?

    [side issue] Pineapple doesn't detect my access point (wireless) anymore, it used to work fine, no settings have been changed and is in range.

  4. Could you try with the -all tag? im almost certain now, that it is at the root of the cause. (the problem is i need that tag for it to automaticly start cracking) and i would like to avoid a total rewrite of wifite.

    and thanks for your information :)

  5. dont worry, you will be able to get it working again for sure.

    you simply made a mistake of formating the SD card. windows wouldnt of understood the ext format the drive was in and wanted to format it, you should have done that.

    Its fine though, just format it in fat32 download though files again put it back in the pineapple follow the inital setup instructions on manual, it takes a few mins. Try not to turn it off before its done.

    if that doesnt work, follow the unbricking instructions. https://wifipineapple.com/?flashing

    Let us know how you go :)

    Good Luck!

  6. the only way to do it, would be a direction antenna at both school and at home, mounted on the roof or somthing, with line of sight between school and home. its just not practicle.

    You would be better off using your schools internet, and if there are restrictions you want to bypass use a tunnel or vpn, most schools dont block this, based on my experience.

  7. This is what happened to me! Except I can't even get a shell through serial. I've been running wifite but not through the dip switches and without a dictionary attack.(I think I may have shutdown the pineapple without completely closing wifite.) I was hoping if I let it sit unplugged for a day or two and try the serial cable again I'll at least get a shell...

    Are you able to get a shell normally? if you expect to get something when its just sitting with the green light on, you might be waiting for a while. i belive the system is halted, a power cycle should work and rerun wifite again.

    where you running wifite.py with the -all switch?

  8. After looking into it further, this doesnt seem to be any help.

    a halt command does the same

    root@Pineapple:/# halt
    root@Pineapple:/# [  228.840000] br-lan: port 2(wlan0) entered disabled state
    [  228.840000] device eth0 left promiscuous mode
    [  228.850000] br-lan: port 1(eth0) entered disabled state
    [  228.860000] device wlan0 left promiscuous mode
    [  228.860000] br-lan: port 2(wlan0) entered disabled state
    [  229.240000] umount: sending ioctl 4c01 to a partition!
    [  229.240000] umount: sending ioctl 4c01 to a partition!
    [  231.270000] Removing MTD device #3 (rootfs_data) with use count 1
    [  231.300000] System halted.
    

    So Wifite (http://wifite.googlecode.com/svn/trunk/wifite.py) appears to force the system to halt.

  9. Starting Wifite                                                                 
                                                                                    
    [  550.190000] device mon0 entered promiscuous mode                             
    [  561.740000] br-lan: port 2(wlan0) entered disabled state                     
    [  561.740000] device eth0 left promiscuous mode                                
    [  561.750000] br-lan: port 1(eth0) entered disabled state                      
    [  561.770000] device wlan0 left promiscuous mode                               
    [  561.770000] br-lan: port 2(wlan0) entered disabled state                     
    Terminated                                                                      
    root@Pineapple:/sd/wifi# [  564.680000] Removing MTD device #3 (rootfs_data) wi1
    [  564.710000] System halted.
    
    
    

    Finally we have a starting point!

    anyone know whats happening?

    from my understanding all of these statements are bad:

    mon0 - promiscuous from monitor mode :(

    br-lan port 2 - wlan0 disabled - (great! AP down :( )

    eth0 le ft promiscuous mode mode - basicly pre-disabled state?

    eth0 - now its disabled

    wlan0 left promiscuous mode, again pre-disabled state (but was prevously disabled???)

    br-lan port 2 (wlan0) - disabled again

    Removing MTD device - (guessing sebkinne will know?)SD card?? sounds bad whatever it is, prob causes the system halt! (problem with firmware?/SD card maybe?)

    system halted - we all know this is bad!

  10. Update:
    Problem 2 fixed! Layer 1 issue haha, so replaced cable from pin to pin and it didnt work so i reversed pins

    GND == G

    RX == T

    TX == R

    Then i realised i was doing it wrong haha

    of course Tx > Rx & Rx > Tx

    For people that dont understand

    you need to recieve the transmition from the pineapple USB RX < PINEAPPLE TX

    the pineapple needs to recieve from pc USB TX > PINEAPPLE RX
    and of course you need GND (ground)

    How quickly you forget these things when you dont use it offen.

    Hope this helps other people. Issue One still remains though, will update soon.

  11. Problem 2: Serial doesnt drop to shell (my attempt to troubleshoot the above issue without network connectivity but for these current tests i can use pineapple like normal eg. wifi/ssh/web interface etc).

    So im connecting using CP2102 to connect via minicom in ubuntu linux and on another pc windows 8.1 & putty.

    3.3v // Not Connected (in what case is this used for the pineapple?)

    G == GND

    R == Rx

    T == Tx

    5v // Not connected

    (order is as if im looking at serial end)

    ive tried reversing Rx and Tx and power cycling many times no luck. I have prevously used the CP2102 to read serial data on a old router (havent tested tx yet).

    Linux ubuntu 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    Distributor ID: Ubuntu
    Description: Ubuntu 12.10
    Release: 12.10
    Codename: quantal

    Welcome to minicom 2.6.1

    OPTIONS: I18n
    Compiled on May 1 2012, 13:36:18.
    Port /dev/ttyUSB0

    115200 8N1

    ive gotten seemly random data (see below):

    < s~~@~<                                         
    @@<d2~?8tpA -
    
    p8|@ "                            
     @~
    
    :7:>?66?6ߟ
    

    Any ideas?

    Anyone experienced this issue?

  12. well it all depends on what you want. Do you want it to be able to get any phone and copy contacts and pictures?

    I know you could do it to a jailbroken iphone easily but as far as doing it to any device i think your diving in too deep. start with cracking a few wifi passwords, and some scripts to automate that process. get to know how linux machines are networked etc.

×
×
  • Create New...