Jump to content

ScottHelme

Active Members
  • Posts

    61
  • Joined

  • Last visited

  • Days Won

    2

Posts posted by ScottHelme

  1. I have problems with Karma on some devices but most work fine. One thing that I have found is how different devices behave in certain circumstances.

    For some devices if they are connected to an AP already and I disconnect them or turn the AP off, they will not be caught by karma. If I then disable and enable WiFi on the device, Karma will grab them. I look at it kind of like the device is coming into range of Karma and couldn't see it previously, rather than it always having been there. Who knows, but it works for me :)

    As I say, some devices get dragged in by Karma first time, every time. Apple devices (pre iOS 7) seem incredibly promiscuous and almost always dive on WiFi immediately. Perhaps they are trying to provide a better user experience by having WiFi as much as possible.

    As for the comments regarding the hardware/project/support/reliability etc... I can understand the concerns expressed here, but I think we need to understand that this isn't a retail level, consumer grade product. The team at Hak5 have created a great product with very little resources at a good price point, something that should be applauded. It's aimed at a more tech savvy audience and is a very niche product. When I purchased mine I expected there would be bumps and hiccups here and there and that I would have to learn something along the way and maybe patch stuff up as I go. Perhaps that's just me but unless I can go and buy this off the shelf at a high street retailer, I'm not going to expect similar levels of support.

    On the bright side, I'm getting a lot more comfortable with things like Linux and the command line since I started using the Pineapple, which is great!

  2. Are you still connected to the pineapple via ethernet? Setup the ICS and try rebooting the device without the ethernet connected, then connect via the rogue AP and see how that goes.

    If that doesn't cure it, SSH to the pineapple and run

    rm /etc/config/wireless && wifi detect > /etc/config/wireless && reboot

    Then setup ICS and reboot again (no LAN cable).

  3. In the Karma config tab the SSID Black / White Listing section doesn't show what mode it's currently in.

    I had a dig in the code and it's trying to run this (/pineapple/components/system/karma/includes/content/config.php):

    Currently in <?=exec('hostapd_cli -p /var/run/hostapd-phy0 karma_get_black_white')?> mode.

    I changed it to remove the = as it didn't look right but that didn't help. Wild stab in the dark!

    Originally spotted by +KaiserBuns on IRC.

  4. Well, you kind of proved my point really. If I had bought it this year, it would still say that on the packaging wouldn't it, because that's what the packaging says! Much like you've bought an older pineapple, it still bears the same packaging it had at release. Packaging isn't generally updated for a product through it's lifetime because that would be incredibly cost inefficient.

    Also, the very first sentence of the advert you linked says "most wireless devices", which is still true. Most wireless devices do still fall for karma.

    No one is jumping down your throat, I'm just pointing out that you say "it doesn't work as it used to be advertised" but nothing does once time has passed by.

  5. I got this working in the end, I've responded to the comment on my blog here: https://scotthelme.co.uk/wifi-pineapple-occupineapple/#comment-1097547220

    Via SSH:

    root@Pineapple:/# opkg remove mdk3
    Removing package mdk3 from sd...

    After this, refresh your web interface, open the occupineapple infusion and install mdk3 to local storage. Once that's done, select the SSID list you want and hit Start.

    mdk3 is running with list SSID_with_MAC.mlist...

  6. It doesn't work as it "used to be advertised", well of course not... Vendors have started to patch security flaws in their products. The description of the product has evolved with the landscape around it. Do you think that just because it used to work perfectly once that it should continue to do so forever? What happens when the WiFi spec is abolished and WiFi v2 comes out? Then it won't work at all...

    I have a Sega Mega Drive upstairs that says cutting edge graphics on the box, but it doesn't deliver that. It's not working as it used to be advertised.

    You should be happy that the security in the WiFi landscape is moving forwards yet worried that a *vast* majority of devices out there are still vulnerable.

  7. Ok, now I get a red LED blinking on for a second, the maybe off for 5.


    root@Pineapple:~# cat /etc/config/wireless

    config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11ng'
    option macaddr '00:13:37:a5:08:bd'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'
    option disabled '0'

    config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Pineapple5_08BD'
    option hidden '0'

    config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11g'
    option macaddr '00:13:37:81:42:22'
    option disabled '0'
    option channel '1'

    config wifi-iface
    option device 'radio1'
    option ssid '*snip*'
    option key '*snip*'
    option network 'wan'
    option hidden '0'
    option mode 'sta'
    option encryption 'mixed-psk+tkip+aes'

  8. Do you have anything plugged into the eth0 port? Also, did wlan1 connect to wlan0? aka testing mode. There is no info in the second wireless config about the client AP that you're connecting to... Also, perhaps an option disabled '0' in each wifi-device section... Once you've done that use the WiFi Manager infusion to select what AP you want wlan1 to connect to then save and commit it. It should work right away and then after reboot the client mode tab should use that new info in /wireless and it should connect automatically.

    Yeah my PC goes into the LAN port which I assume is eth0. That's how I'm setting this up atm. It should be connecting to my home AP as I select it from the drop down and put the WPA key in. Will try the other stuff now.

  9. cat /etc/config/wireless prior to connecting

    root@Pineapple:~# cat /etc/config/wireless
    config wifi-device radio0
    option type mac80211
    option channel 11
    option hwmode 11ng
    option macaddr 00:13:37:a5:08:bd
    option htmode HT20
    list ht_capab SHORT-GI-20
    list ht_capab SHORT-GI-40
    list ht_capab RX-STBC1
    list ht_capab DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1

    config wifi-iface
    option device radio0
    option network lan
    option mode ap
    option ssid Pineapple5_08BD
    option encryption none

    config wifi-device radio1
    option type mac80211
    option channel 11
    option hwmode 11g
    option macaddr 00:13:37:81:42:22

    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1

    config wifi-iface
    option device radio1
    option network lan
    option mode ap
    option ssid Pineapple5_4222
    option encryption none

    cat /etc/config/wireless after connecting

    root@Pineapple:~# cat /etc/config/wireless

    config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11ng'
    option macaddr '00:13:37:a5:08:bd'
    option htmode 'HT20'
    list ht_capab 'SHORT-GI-20'
    list ht_capab 'SHORT-GI-40'
    list ht_capab 'RX-STBC1'
    list ht_capab 'DSSS_CCK-40'

    config wifi-iface
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Pineapple5_08BD'
    option encryption 'none'

    config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option macaddr '00:13:37:81:42:22'

    config wifi-iface
    option device 'radio1'
    option mode 'sta'
    option network 'wan'

    wlan1 is reporting the IP 172.16.42.204 which is not what my DHCP server is dishing out.

×
×
  • Create New...