Jump to content

HomoHabilis

Active Members
  • Posts

    8
  • Joined

  • Last visited

Posts posted by HomoHabilis

  1. I've reflashed my fon 3 times the day before writing this topic...

    Reflash is an option if you screw something up, but don't reflash too often.

    UPD: Pineapple is a nice toy, however it requires a basic(maybe Intermediate) knowledge in Networking

    All tutorials and stuff

    assume that a pineapple owner knows such things as

    - what network mask is used for

    - what is the ip class

    - what is the gateway

    etc..

    so for a Brand new person, I would recommend to study basic networking first

  2. Greetings fellow pineapple lovers!

    I don’t know if it is any useful to you (I would love to have what I’m writing right now a few days ago anyways).

    Before we start, know if you cannot undo changes you've done to your pineapple

    consider reflashing it (reflash guide on the hak5.org homepage) or Here.

    *Note :If you have changed your pineapple IP to something else than 192.168.1.1,

    after the flashing utility closes, change the static ip of your Ethernet adapter to

    IP : 192.168.1.(any value int that ip range not 0 not 255) ex: 192.168.1.113

    MASK: 255.255.255.0

    Gateway: 192.168.1.1 (your pineapple IP)

    since the default ip of the pineapple after reflash is 192.168.1.1

    First of all, if you want to follow the tutorial, take note of the weird corruption inside wireless file.

    Erase everything above this line

    root@OpenWrt:/etc/config# cat wireless

    Including the line ;)

    if the wireless file looks like this:

    config wifi-device  wifi0
            option type     atheros
            option channel  5
            option mode     '11bg'
            option diversity        '0'
            option disabled '0'
    
    
    config wifi-iface
            option device   wifi0
            option network  lan
            option mode     ap
            option ssid     'Get RickRolld'
            option encryption none
            option hidden   '0'
            option isolate  '0'
            option txpower  '0'
            option bgscan   '0'
            option wds      '0'

    than no need to remove anything ;)

    Secondly, the dhcp file doesn’t allow a client to acquire an IP adress...

    So,I screwd it up a little … you can try this one :

    config dhcp
            option interface        lan
            option start    100
            option limit    150
            option leasetime        '720m'
    
    config dhcp
            option interface        wan
            option ignore   '1'
            option start    '100'
            option limit    '150'
            option leasetime        '720m'
    
    config dnsmasq
            option authoritative    '1'
            option domain   'lan'
            option local    '/lan/'
            option boguspriv        '0'
            option filterwin2k      '0'
            option localise_queries '1'
            option expandhosts      '1'
            option nonegcache       '0'
            option readethers       '1'
            option leasefile        '/tmp/dhcp.leases'

    Thirdly, if you have webif, before moving Rick’s index.html into /www

    Change webif’s index.html to any .html filename you like…. In case you need webif after…

    http://yourPineappleIP/nameOFwebIf.html

    Finally, take note,

    https:// URLs from bookmarks and even “aaaa” typed in the browser will give an error,

    wouldn’t it be nice to set 404 error to the /www/index.html?

    touch /etc/rrhttpd.conf
    echo "E404:/www/index.html" > /etc/rrhttpd.conf
    

    open up /etc/init.d/httpd

    above thos line:

    eval "$HTTPD_BIN $args"

    add the line

    append args "-c /etc/rrhttpd.conf"

    UPD: I think editing the httpd doesn't require system reboot,

    anyways try:

    /etc/init.d/httpd restart

    Modified (a little)

    Source for this final step are from guide :by Psychosis

    Note: if you do this Webif will print out a page saying "Permission denied"

    if you want to modify something using webif just comment the line

    in /etc/init.d/httpd

    by adding a pound, like this:

    #append args "-c /etc/rrhttpd.conf"

    Note: everytime you modify the file you need to rebot or restart httpd

    hope this would help n00bs just likemyself.

  3. Hello,

    I have a same problem, I followed your guide and DigiNinja mind map (a.k.a pdf how to setup ICS on linux)

    fon ip : 192.169.200.250

    MITM (BT4 r2) eth0: 192.169.200.113

    victim ip: 192.169.200.239

    on a victim PC i have gateway 192.169.200.250(fon ip)

    ping 192.169.200.250 - win (obviously)

    ping 192.169.200.113 - win " "

    ping 8.8.8.8 - FAIL!

    where did I Screwd up?

    /etc/config/network

    config interface loopback
            option ifname   lo
            option proto    static
            option ipaddr   127.0.0.1
            option netmask  255.0.0.0
    
    config interface lan
            option ifname   eth0
            option type     bridge
            option proto    static
            option ipaddr   192.168.200.250
            option netmask  255.255.255.0

    /etc/config/dhcp

    config dnsmasq
            option domainneeded     1
            option boguspriv        1
            option filterwin2k      '0'  #enable for dial on demand
            option localise_queries 1
            option local    '/lan/'
            option domain   'lan'
            option expandhosts      1
            option nonegcache       0
            option authoritative    1
            option readethers       1
            option leasefile        '/tmp/dhcp.leases'
            option resolvfile       '/tmp/resolv.conf.auto'
            list 'dhcp_option' '3,192.169.200.113'
            list 'dhcp_option' '6,8.8.8.8'
    
    config dhcp lan
            option interface        lan
            option start    100
            option limit    150
            option leasetime        12h
    
    config dhcp wan
            option interface        wan
            option ignore   1

×
×
  • Create New...