Jump to content

TylerCPU

Active Members
  • Posts

    145
  • Joined

  • Last visited

Posts posted by TylerCPU

  1. TLDR: SSH to pineapple then issue the command mkdir /pineapple/logs

    I know I already sent you the message, but for other people that have the problem here's the solution.

    I don't know why you are getting that weird message in your logs. I get the same thing too.

    In the root directory find the "pineapple" folder and while your in there create a folder called "logs". That's it. You should see your phishing logs now in there. When the error.php file tries to write in the "/pineapple/logs/" folder it fails because the folder "logs" is not there. Hope that helps.
  2. 2 quick things.

    Technical tid-bit:

    With the 4GB SanDisk Cruzer Fit version 1.26 the MK4 (version 2.7.0 - 2.8.1) will report the USB device as available from lsusb and mounted on /usb from df -h, however the drive is not functional. What happens is the drive is initialized on boot when the MK4 has ample power, before the radio comes up. Once the radio comes online it "steals" power from the bus and the USB drive, while reported, is nonfunctional.

    Upcoming replacement drive:

    I just spoke with our vendor and we'll have replacements in 2 weeks laser engraved with the Hak5 logo. Here's a sample. If you can't wait we're more than happy to send you the Domain.com printed drive or if you can wait we'll get you one of these. They look fantastic but either way it's the same hardware underneath. R/W performance is comparable to the SanDisk.

    GLOcKoKl.jpg

    That explains so much. Thank you. I got my sandisk from amazon and it's the 1.26 firmware. It was awfully flaky the drive. It would work for me and then mostly quit. When can I get the new drive? I think it's cooler than the sandisk.

  3. It looks like your USB drive may not mounted right. What firmware version are you running? Update it to the latest version. Currently it's 2.8.1. Reformat the usb flash drive and setup the swap again. Follow this.

    Also don't use a portable power pack. Just use the wall adapter for power for now and see if that is the problem. Some usb flash drive don't work well with low power.

  4. I had this exact same problem.To fix this just go to the etc/config/wireless file and change the "option network lan" under "config wifi-iface" to "option network wan". Also make sure your wireless card is in managed mode not AP mode. For more information on setting this up check this out.

  5. Same issue. Also does not work when using the pineapple juice (which really frustrated me). I feel for you. Very frustrating when you purchasing things from a store expecting them to work with one another and no mention through the store that they do not. The hakshop still doesn't say anything about this issue and it has been reported numerous times in the forums. The lack of communication (or lack of caring, but I am attempting to give the benefit of the doubt) is atrocious.

    I bought mine off of amazon, but it's the same as hak5s I think. Sandisk Cruzer Fit 4GB.The weird thing is mine doesn't automatically power on anymore. The drive looks dead until I reinsert the USB drive back in(sometimes more than once) using the 2.8.1 firmware.

    Mine works fine using my pineapple juice(mostly). Everything works fine for me. I have to idea why, but it does. So the drive is completely dead for you on the pineapple?

  6. Alright so I am trying to get the handshake of a wpa-psk connection with the wifi pineapple.

    Unfortunatly the files are creating in the root of the pineapple, and after some time it's full. So how can I scan with airodump-ng and the file go directly to usb instead of root?

    I haven't played with airecrack, but to store the files on the usb drive all you have to do is change the path. The usb drive is mounted in the folder called /usb.

  7. I'm getting the "Invalid request path ''" bit even on a simple page load. I'll have to dig back into it when I have more time this week.

    As for not being able to access the pineapple interface, that's a bit easier to explain - you need to review the firewall controls in your nodogsplash.conf. It's got separate classes of controls for unauthenticated users, authenticated users, and access to the pineapple itself. Make sure you have a listing for access to the administrative interface port (tcp/1471 or whatever you've set it to). If you want to be a bit more granular, you can also whitelist the MAC of a single device.

    Thanks. I forgot about the firewall. *facepalm* Anyways if anybody wants to get access back on the pineapple interface just look for " FirewallRuleSet users-to-router { " in nodogsplash.conf and under that add

    FirewallRule allow tcp port 1471

    FirewallRule allow udp port 1471
    That's it. Thanks @ravenium. I don't think you need udp but I put it there just in case.
  8. Hello,

    I flshed my Pinapple with 2.8.1

    If I go to 172.16.42.1:1471 I can see

    I changed the "/etc/config/uhttpd and look for "list listen_http 0.0.0.0:80" to list listen_http 0.0.0.0:81

    I rebooted

    I then installed nodogsplash as above.

    If I then go to 172.16.42.1:1471 I can see I see the status page as I am suppose to

    if I then SSH into pineapple and start nodogsplash

    If i Then try and go 172.16.42.1:1471 I get "a blank page with the messgae " Unable to connect "

    If I open another tab and type in "google.com" I get the standard splash page with the dog. If I press on the dog It says connecting to google but it never loads

    any ideas what is wrong ?

    Thanks

    I always had problems with nodogsplash. So far what I was able to find out is that you don't need to change the uhttpd port to 81 from 80. Nodogsplash runs on port 2050. So no clashing there. The reason why I said that was because of what darren said

    . When nodogsplash is running I can't access the pineapple web interface either. For some weird reason when I click on the dog on my phone it sits there and loads forever but if I try and load a different page my internet works fine on my phone(Samsung Galaxy SIII).On a desktop it's a different story. I get the "unable to connect" on google chrome in Windows on every site after it loads for awhile. The weirdest thing is this.
    root@Pineapple:~# Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path ''
    Invalid request path '' 

    I get this in my ssh connection when I try and load a webpage on another desktop computer but then fails to load it. I think that the nodogsplash redirect feature is broken(after you click on the dog).

    I wish some of the devs would explain what is wrong or what I'm doing wrong. It just seems broken to me. I'm doing the same thing darren is doing in ep. 1401.1. I'm in the same boat as you. Never really worked for me.

  9. I am assuming you made a new subnet. You are going to need to add it to your routing tables (correct me if I am wrong).

    I don't know if I created a new subnet. I didn't want to mess with that so I used a totally new IP address range 10.x.x.x.

    I guess I did make a new subnet. I used 255.255.255.0 for the netmask instead of the normal 255.0.0.0.

    I totally forgot about the routing tables, but I don't know what commands to use to point the 10.0.0.0 to the default gateway. I looked all over the web, but I couldn't come up with anything. I tried changing the gateway for 10.0.0.0 from * to 172.16.42.42, but it makes it for br-lan not br-guest. The new defined network in /etc/config/network. So here is my routing table.

    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         172.16.42.42    0.0.0.0         UG    0      0        0 br-lan
    10.0.0.0        *               255.255.255.0   U     0      0        0 br-guest
    172.16.42.0     *               255.255.255.0   U     0      0        0 br-lan
    root@Pineapple:~#
    
    
    

    Ideally I would like the new wifi network "Hotspot" to be on a separate network with the traffic pointing to the default gateway. I want it to be compatible with my setup. Wi-Fi------- Laptop-------- Ethernet to pineapple------- Wi-Fi out. Normal ICS. I don't know much about networking. Any help will be greatly appreciated.

  10. I tried making a new ssid/network separate from the pineapple ssid. For guests only(to be used for nodogsplash). I can connect to it and get a dhcp address but no internet access. Normal setup ICS with laptop. Here's my network/dhcp/wireless files. Any help will be appreciated. Thanks.


    config 'dnsmasq'
    option 'domainneeded' '1'
    option 'boguspriv' '1'
    option 'filterwin2k' '0'
    option 'localise_queries' '1'
    option 'rebind_protection' '1'
    option 'rebind_localhost' '1'
    option 'local' '/lan/'
    option 'domain' 'lan'
    option 'expandhosts' '1'
    option 'nonegcache' '0'
    option 'authoritative' '1'
    option 'readethers' '1'
    option 'leasefile' '/tmp/dhcp.leases'
    option 'resolvfile' '/tmp/resolv.conf.auto'

    config 'dhcp' 'lan'
    option 'interface' 'lan'
    option 'start' '100'
    option 'limit' '150'
    option 'leasetime' '12h'
    option 'ignore' '0'
    list 'dhcp_option' '3,172.16.42.42'
    list 'dhcp_option' '3,172.16.42.1'
    list 'dhcp_option' '6,172.16.42.1,8.8.8.8'
    list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

    #config 'dhcp' 'wan'
    # option 'interface' 'wan'
    # option 'ignore' '1'
    # option 'start' '100'
    # option 'limit' '150'
    # option 'leasetime' '12h'
    # list 'dhcp_option' '3,172.16.42.42'
    # list 'dhcp_option' '6,172.16.42.1,8.8.8.8'
    # list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

    #added below-----------------------------------------
    config 'dhcp' 'guest'
    option 'interface' 'guest'
    option 'start' '100'
    option 'limit' '150'
    option 'leasetime' '12h'
    list 'dhcp_option' '3,172.16.42.42'
    list 'dhcp_option' '3,10.0.0.1'
    list 'dhcp_option' '6,10.0.0.1,8.8.8.8'
    list 'dhcp_option' '6,10.0.0.1,208.67.222.222'

    # Copyright © 2006 OpenWrt.org

    config interface loopback
    option ifname lo
    option proto static
    option ipaddr 127.0.0.1
    option netmask 255.0.0.0

    config interface lan
    option ifname eth0
    option type bridge
    option proto static
    option ipaddr 172.16.42.1
    option netmask 255.255.255.0
    option gateway 172.16.42.42
    option dns 8.8.8.8

    config interface wan
    option ifname eth1
    option proto dhcp

    config switch eth0
    option enable_vlan 1

    config switch_vlan
    option device eth0
    option vlan 1
    option ports "0 1"

    config interface usb
    option ifname usb0
    option proto dhcp

    #added below----------------------------------

    config 'interface' 'guest'


    option type bridge
    option 'proto' 'static'
    option 'ipaddr' '10.0.0.1'
    option 'netmask' '255.255.255.0'

    config wifi-device radio0
    option type mac80211
    option channel 11
    option hwmode 11ng
    option macaddr 00:c0:ca:60:57:4e
    option htmode HT20
    list ht_capab SHORT-GI-20
    list ht_capab SHORT-GI-40
    list ht_capab RX-STBC1
    list ht_capab DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1

    config wifi-iface
    option device radio0
    option network lan
    option mode ap
    option ssid "pineapple 57:4e"
    option encryption psk2
    option 'key' '12345678q'

    #--------------------------------------
    config wifi-iface
    option device radio0
    option network guest
    option mode ap
    option ssid "Hotspot"
    option encryption none

    I used this how to guide here.

  11. Hello,

    I do not think so i stoped it with

    /etc/init.d/uhttpd stop

    /etc/init.d/uhttpd disable

    That did not do it.

    I'll try and mess with it and see what happens. To change your port number on uhttpd go to /etc/config/uhttpd and look for "list listen_http 0.0.0.0:80" on the top and change the 80 to like 81.

  12. Hello,

    I installed Nodogsplash on 2.8.1 and I have the following issue.

    After reboot if I connect over wireless to the pineapple I can go to google.com no problems.

    When I then start nodogsplash via ssh and then call google.com I get the nodogsplash page. If I then press on the dog it should forward me to google.com . But I get the loading until it goes to the error pages and does not load.

    any Idea what the problem could be ?

    Thanks

    I haven't played with it for awhile, but your mircohttpd(webserver for phishing) is clashing with nodogsplash on port 80. Just change the mircohttpd to another port number like 81. Hope that helps.

  13. Well, I just got my Sandisk Cruzer Fit 4GB from amazon and it works just fine. I don't have any of the problems other people are having. I don't know what is going on. It just works.

    Anyways here is my testing with the that flash drive plugged in. The testing was done from the output of the usb(from my computer) that powers the pineapple.

    Note: Power consumption(amps) does not change whether plugged into a wall adapter or usb port.

    Power consumption(amps):

    5V----170 milliamps

    5V----230 milliamps spike

    No sandisk plugged in:

    5V---- 150 milliamps

    5V---- 200 milliamps spike

    It looks like the pineapple does not require very much power so I highly doubt it's a power problem.

    USB 2.0 spec supports 500 milliamps. I did short circuit my usb port to see how much current would flow(Don't do it you could damage your computer.)

    It was at 300 milliamps.

    USB out on pineapple 4.12V

  14. Problem not solved. Using a different USB drive does nothing to mitigate the problem. Users/admins, please post constructive suggestions and/or comments that demonstrates creative thinking and problem solving.

    Furthermore, what is most frustrating is that I purchased the San Disk drive specifically because it was suggested as a low-power, discrete, and capable USB drive by the creators of Hak 5 products.

    If anyone has more insight into this problem please let those of us experiencing it know. Thanks!

    Well it looks like a power problem. How many milliamps/volts is your computer putting out of your usb port for the pineapple? See this. BTW I just ordered that drive to see for myself the problems you guys are having.

    If you have a volt meter and a spare USB cable rip that apart and see the volts/amps that it's outputting with the pineapple powered. Then start comparing with the USB drive to the computer, computer to pineapple to usb. Then you'll know where you're at with power and compare that with other people that are not having problems.

×
×
  • Create New...