Jump to content

MK1: Step-By-Step Unlocking / Install guide (with pictures)

Recommended Posts

  • 4 weeks later...
  • Replies 172
  • Created
  • Last Reply

Top Posters In This Topic

  • 3 months later...


I am a complete noob. And after i have spend ages on downgrading my secondhand fon I now finally started with the guide. But I am tuning in to a problem in step 8. I have no idea how to copy those files to /temp/. Could someone help me with this? I have been googeling al night but I just can't get it to work. I am completely new to ssh.

Link to comment
Share on other sites

don't have time to look at the wiki but to copy files you do

cp <the filename> <destination>

so to copy a.html to /tmp do

cp a.html /tmp

Can I suggest if you are that new to linux then you are best learning some linux stuff before playing with Jasager otherwise you'll be asking questions every 5 minutes and won't get the best out of it.

Link to comment
Share on other sites

Thank you very much. Yes I am playing around with Linux for a couple of weeks now. Becouse as you noticed up till now a run into a lot of problems. Never the less I would like to ask you how it is possible to copy the files to the fon using putty in windows. I was able to log into the router only I don't know how to use the scp command. I put the two files into the c: directory. Hope you can help me with this.

Link to comment
Share on other sites

  • 2 months later...

Hi everyone, this is my first post. I have been reading the forum for some months mow, and watching the show for 2 years but it wasnt untill now that I decided to post.

My problem is that I followed this guide today (because the one for the firmware version of Jasager in digininjas page wasnt working for me), i got to point 9. When I rebooted and tryed to run step 10 then "out.hex" wasnt in tmp anymore.


I transfered it again and run the command on step 10, run reboot and...

almost an hour later my fon2100 is not broadcasting myplace anymore, and no blinking leds, only the rightmost one constantly on...

I could really use some help here, I know this is an old thread but please, Please help me!!

Btw, thanks digininja and darren for promoting this, and helping people out.


Link to comment
Share on other sites

  • 1 month later...

Dijininja - I'm missing something apparently when upgrading my software.

I had a Fon2100 setup with Jasager v.1 back when this project first kicked off and decided I'd upgrade using your new firmware.

Here's my situation.


Ethernet cabled Fon router to computer.

Assigned my computer static IP of with gateway

Downloaded FonFlash from Gargoyle Router Management site.(http://www.gargoyle-router.com/download.php)

Downloaded your newest firmware as posted here.(http://www.digininja.org/files/jasager_firmware_1.0.tar.bz2)

Untarred with 7zip. Proud owner of two new files. (openwrt-atheros-vmlinux.lzma) & (openwrt-atheros-root.squashfs)

Opened FonFlash. Left 'OpenWrt/Gargoyle' - Used my two new files as sources for Rootfs and Kernel.

Clicked 'Flash Router Now'

Roughly 15 minutes later got a nice dingy sound stating success & that router was restarting.

Now here is where I'm stuck. The router doesn't respond to pings.

Tried to telnet to and nothing happens. Firewall turned off to ensure traffic flow.

Tried to ssh to - nothing happens.

Using Putty.

Can't rely on DHCP settings in windows because Fon won't lease an IP address. What I'm wondering is - what's the default IP for the Fon2100 using your firmware install method?

I'm hoping it's something simple I'm just overlooking.

Link to comment
Share on other sites

  • 4 months later...

After I install webif and try to open it with a browser under, I get asked for the openwrt pass, but then after I enter it hit enter I get redirected to a blank page, like there is literally nothing but a white screen. Did I Miss something?

Link to comment
Share on other sites

  • 9 months later...


I apologize for reviving such an old thread. Though, I was digging through my storage the other day and I managed to find an un-opened FON 2100.

Naturally first thing I thought to do, was to make a pineapple out of it. As I said it was un touched so it still had the original firmware on it. I was following the tutorial nicely, though when I came to step 9, I patched it and proceeded with the reboot (I commanded it to reboot, if that makes any sort of difference).

Though now the problem is, it is not re-booting back up. I let it sit for quite a few minuets and nothing happens (no WLAN light comes on, also I don't see "My Place" on available networks)

Did I brick my FON? I am confused as to what to do, I have even tried pressing the reset button at the bottom to attempt to restore the original firmware.

Any help on the matter would be greatly appreciated.

Thanks in advance!

Link to comment
Share on other sites

Haven't played with the fon in a LONG time. My old 2100 still has the mark 1 firmware on it lol. The reset button only resets the changed settings of the firmware, not the firmware itself. I don't remember what step 9 is but I do remember the DIY mark 1 was kind of a pain lol. All I can suggest is try searching on the forums and see what you can find. Scattered all over the forums is all the info, but I think the mark 3 firmware will run on it. It would be just a matter of firmware flashing it. The only thing is it may be a little slow due to the slower hardware on the fon2100 vs the AP51.

Link to comment
Share on other sites

You can try the flashing guide described on the wiki.

Go for the Method 1, with the utility ap51-flash, it is the easier way to flash it.

While possible, the current firmware will probably be too heavy for the old FON.

I haven't gotten around to releasing a slimmer firmware, it is something I will do after I finish other work.

You can give it a shot though. Just a warning: Turning on URLSnarf can reboot the FON because the CPU load gets to 100%. once that happens the FON automatically reboots.

Link to comment
Share on other sites

Thanks for the replies everyone, yes I know it is an old piece of hardware lol. Though, hell it is a free piece of old hardware. You can't beat that price and I guess I can do something cool with it.

I did manage to figure it out. I was using the ap51 flash utility incorrectly. Now, with that said and done, got it up no problems :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...