Jump to content

Help with Light control script


Recommended Posts

Hello there!

I've tried and Tried but I cant get the light script to work, I know its probably something stupid but I'm completely oblivious.

first off my apache folder is located at C:program filesapache software foundationapache2.2

in htdocs I have index.php (gives me errors when its .html)

I cant access this page by typing http://localhost , I get a directory listing of my music fodler (password protected) but I ebleive this is simply a mistake on my part in confhttpd.conf

I have the firecracker (I've verified it works) located on COM1 but it has a thermosensor cirucuit (small PIC with attatched thermoressistor, the program I found only works on com1) this device measures and records the temp every 30 sec. so maybe there's a conflict.

I am using the code provided in episode 1, but when I click Off nothing happens. I do not know where I should put light.exe (/bin ?)

thanks for any help you can give

Link to comment
Share on other sites

http://localhost/index.php does not get me where i want to be

If I put a file named Index.php in the directory that comes up when I type http://localhost/

It just gives me the same listing with a file named Index.php, however by changing it to index.html I get the page with the two buttons like I'm looking for, however when I click on either of the buttons I get the error:

Not Found

The requested URL /index.php was not found on this server.

Where is the directoryindex located?

the Getcwd file emntioned was in my Perl dir, I am unsure how to find my Path

Link to comment
Share on other sites

Well shouldn't you have both a index.html and index.php then? Presumably the first will have the buttons in it and the latter will have whatever PHP is supposed to be in there in it.

WINDOWSSystem32 will be in your path, you could put it there.

Link to comment
Share on other sites

I split it up so all the HTML was in the index.html file and the Php script is in index.php.

the files are located so that when I type http://localhost I get the website with two buttons

however when I click those buttons it shows me a page showing my php

lights.exe is in ststem32

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...