Jump to content

Automatic Read Only Problem


dragoon670
 Share

Recommended Posts

So I just got a WD Passport 320 GB external drive. I formatted it from FAT32 to NTFS using windows, and transferred some files to it. I then took the drive to school and discovered that for some reason i couldn't write to the root, unless i was moving over a folder. I thought it was a quirk, so i ignored it. at the end of the night I tried to back up my work, but it said it couldn't overwrite the files on the hd. I checked the properties, and every folder on the drive has a greyed out read only check-mark on it. I tried a couple times to remove it, but each time it just replaces itself. well I opened the properties of a folder I had taken off said drive, and it too had this read only semi-flag on it. but I needed to back up this folder, so I put it on my ipod which i had with me and use as another disk. I got home and thought maybe my computer could remove the read-only, like it was some sort of user doesn't have permissions error, but no luck. and now, my homework is read only. any ideas on what i did/ should do?

EDIT: Both Machines are using WindowsXP Pro, I'm using SP3, school is using SP2 I believe.

Edit 2: Apparently despite having the read only flag, my home computer has full access to the drive and can overwrite any file, and write directly to the root. any ideas as to why i don't have that level of control with my school computer?

Link to comment
Share on other sites

So I just got a WD Passport 320 GB external drive. I formatted it from FAT32 to NTFS using windows, and transferred some files to it. I then took the drive to school and discovered that for some reason i couldn't write to the root, unless i was moving over a folder. I thought it was a quirk, so i ignored it. at the end of the night I tried to back up my work, but it said it couldn't overwrite the files on the hd. I checked the properties, and every folder on the drive has a greyed out read only check-mark on it. I tried a couple times to remove it, but each time it just replaces itself. well I opened the properties of a folder I had taken off said drive, and it too had this read only semi-flag on it. but I needed to back up this folder, so I put it on my ipod which i had with me and use as another disk. I got home and thought maybe my computer could remove the read-only, like it was some sort of user doesn't have permissions error, but no luck. and now, my homework is read only. any ideas on what i did/ should do?

EDIT: Both Machines are using WindowsXP Pro, I'm using SP3, school is using SP2 I believe.

Edit 2: Apparently despite having the read only flag, my home computer has full access to the drive and can overwrite any file, and write directly to the root. any ideas as to why i don't have that level of control with my school computer?

Not sure how this is affected on a portable drive though, as any machine connected to is should be able to access it unless you set some permissions not to allow it. Was the drive set to be a portable drive or fixed drive? You could try modifying ownership of the files and adding a new user, say from the school pc or just take ownership as user from the school pc(unless your not the admin on the school pc, I don't know if you can change ownership of files on external media). NTFS file permissions on folders gives users access to the folder per user basis unless "everyone" user is set to have full control. If the user isn't added to the file or folder ont he external drive, then you may only have read access to the drive(or whatever default ownership permissions were present).

Usually external drives get formatted as fat16/32 unless you need NTFS permissions on certain things. An OS like Windows 98 won't be able to read or recover files on an NTFS drive, so if you wanted to recover these later from a pc that doesn't have an NTFS file system, you won't be able to read the drive. I don't think that is your problem though as you said they were both XP, and I imagine both NTFS file systems.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...