Jump to content

Pandora Timeshifting App: Main Discussion Thread


irieb
 Share

Recommended Posts

Guest t3chn0b0y
I like to run firefox portable out of my usb drive. i installed pandora.jar in my c drive. i run the .bat file and then launch firefox portable and insert the http://localhost and pandoras jar launches and starts playing music. but when i try to grab mp3 files it gives me a error that i am not using firefox. i guess my question is has anybody gotten pandoras jar to work in firefox portable and if they have please post some instructions to do so.

on the root of my usb drive I have

jre1.5.0_07 "java"

Pandora "pandora.jar & sources"

in a programs folder i have

coolplayer "mp3 player"

mpui "a media player for divx movies :)"

portablefirefox "firefox"

I copied all the plugins from my fullversion of firefox over

to the protablefirefox folder.

remember to add the java to the usb drive.. it helps when

pluging into other machines..

now you will want to edit your pandora.bat in the pandora folder

@echo off

start jre1.5.0_07binjavaw -jar pandorapandora.jar 8085

start programsportablefirefoxportablefirefox.exe http://localhost:8085

If you notice i didnt give it any drive letters, that way it would work

on any computer i hooked it up with.. the firefox,pandora jar, java,and

plugins can now run fine from the drive independantly without any

requirements on the machine.. other then the temp directory being

used for the login cookie and cache for the mp3's being saved.. which

end up stored on the usb once they are renamed. Might be an idea to

flush the cache etc on the computer your using when timeshifting.;)

i then compiled the batch file with a program called Quick batch compiler

associating it with the icon in the source folder of pandora jar, this gave it

a nicer appearance in the directory.. :D

then i created a autorun.inf, which gives the drive the pandora jar icon

when plugged in..

[autorun]

open=pandorapandora.exe

action=pandorapandora.exe 

icon=pandorapandora.exe

label=Pandora_Jar

shell=Pandora_Jar

shellPandora_Jar=Pandora_Jar

shellPandoracommand=pandora.exe

shellexecute=pandorapandora.exe

maybe top that off with a start.ini

[SplashStart]

ExecutePath=pandorapandora.exe

ImageFile=pandoraskinsstart.bmp

Delay=4500

DelayLaunch=50

you don't have to goto that extreme.. just make sure you copy

the firefox plugin files over to the firefox on the usbdrive, and version

8 of flash is in there.. copy the java from the hard drive over from the

c:program files directory.. change the information in the pandora.bat,

and you might want to check your

default.properties.. make sure its set to something like this

mp3.archive.path=/

mp3.retry.count=10

that should create an mp3 directory on your usbdrive, on the root

when timeshifting.. and if its not your machine your using don't

forget to logout..

i hope that was of some help... and dont forget to shout at the

devil :twisted: :twisted: rock on :twisted: :twisted:

Link to comment
Share on other sites

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

by the way for those looking for the "old" 7.4.1: wildandbad is online again! Get it from there and recompile with the fixes posted here. (and after you did that, upload it somewhere for me! :-P)

Zoltan, you got us to 1000th message... :shock:

Hmm looking over 7.4.1 there is no build.xml .. so im unable to

compile it.

hehe great! ;)

humm... so which version are you currently using?

Link to comment
Share on other sites

Guest t3chn0b0y
Zoltan

hehe great! ;)

humm... so which version are you currently using?

Im using 7.3.1 right now.. but i dont use the lastfm like alot of other

people enjoy using.. so im not caught up in alot of the problems

Link to comment
Share on other sites

I have some weird issues while saving tracks from Pandora. It only saves the 1st track everytime I boot up my PC. Looking into the debug file, I found the following:

DEBUG Thread-2 util.Mp3Processor - recent non mp3 file found: pandoras-jar-beta-patched-by-proge-1.zip - will continue to next file

DEBUG Thread-2 util.Mp3Processor - file java_install_reg.log is not an mp3

DEBUG Thread-2 util.Mp3Processor - no more mp3 found in dir

DEBUG Thread-2 util.Mp3Processor - sleeping for a second

WARN Thread-2 properties.DefaultProperties - Unable to load tmp mp3 retry count property.

DEBUG Thread-2 util.Mp3Processor -

***processing directory: Temp***

Wonder if it points to anything. Can someone please help on this.

I am using 7.3.1 with Java 1.5 on a Win2k machine

Link to comment
Share on other sites

Guest t3chn0b0y
I have some weird issues while saving tracks from Pandora. It only saves the 1st track everytime I boot up my PC. Looking into the debug file, I found the following:

Make sure your using flash 8 and not flash 9 for starters.

The latest Firefox should do okay, I have jdk1.50.0_07, and

jre1.5.0_07 installed for the java. and make sure you clean

out your cache..

Link to comment
Share on other sites

Guest t3chn0b0y

How am i suppose to compile 7.4.1 with ANT there is no BUILD.XML?

I noticed something when playing around with 7.4.1 it appears to

be putting the mp3's in a folder with my pandora name, where in

the code is that at right now, things have changed quit a bit, I was

going to try and get it so it would do the station name instead.

Link to comment
Share on other sites

Is anyone running this program off of a locked computer?.....my computers are setup in such a way that im not able to access much, so i would have to put flash 8, java, firefox all on my flash drive, anyone know how to do this, and what i have to change to get it to point to the correct place......also having problems with getting file to be recognised due to the fact that depending on where i plug in my flash drive it changes drive name ...EX. G: , E:, F:

Pm me for specifics

thanks in advance

Link to comment
Share on other sites

I have some weird issues while saving tracks from Pandora. It only saves the 1st track everytime I boot up my PC.

I have the same issue. Pandora's Jar saves only one file. To save another file, I have to restart Pandor's Jar and Firefox. This happens even if I have it set to Cruise Control -- it saves the first file but no more.

I have 7.3.1, the latest versions of Java and Firefox, and Flash 8, on WinXP. I've recently emptied my cache.

Thanks for any advice!

Link to comment
Share on other sites

OK I downloaded flash 8 and downgraded to it. I'm running the most recent firefox, and it still wont rip anything. After I downgraded it created the mp3 folder finally under pandora's folder (C:pandoramp3) but the window says "unable to rip mp3 null)

Whats going on here?

Link to comment
Share on other sites

Guest t3chn0b0y
OK I downloaded flash 8 and downgraded to it. I'm running the most recent firefox, and it still wont rip anything. After I downgraded it created the mp3 folder finally under pandora's folder (C:pandoramp3) but the window says "unable to rip mp3 null)

Whats going on here?

Did you use the unistaller, there is a particular one, that will

remove all traces of 9.. and then you can install version 8...?

Link to comment
Share on other sites

Guest t3chn0b0y
Is anyone running this program off of a locked computer?.....my computers are setup in such a way that im not able to access much, so i would have to put flash 8, java, firefox all on my flash drive, anyone know how to do this, and what i have to change to get it to point to the correct place......also having problems with getting file to be recognised due to the fact that depending on where i plug in my flash drive it changes drive name ...EX. G: , E:, F:

Pm me for specifics

thanks in advance

I explained to the best of my knowlege. at least the way i did it,

in a previous post, look back a page or two...

Link to comment
Share on other sites

Guest t3chn0b0y
Did you use the unistaller, there is a particular one, that will remove all traces of 9.. and then you can install version 8...?

Yes I used the uninstaller at the macromedia site then installed 8. Should I use a different one?

No thats the right one...

Link to comment
Share on other sites

Guest t3chn0b0y
Did you use the unistaller, there is a particular one, that will remove all traces of 9.. and then you can install version 8...?

Yes I used the uninstaller at the macromedia site then installed 8. Should I use a different one?

No thats the right one...

Link to comment
Share on other sites

Did you use the unistaller, there is a particular one, that will remove all traces of 9.. and then you can install version 8...?

Yes I used the uninstaller at the macromedia site then installed 8. Should I use a different one?

No thats the right one...

sooo...?

Link to comment
Share on other sites

I've recently installed PJ and tried letting it run overnight on one of my stations - with um.. mixed results. I managed to identify the behaviour (I think) that is causing me problems:

in manual mode, I grab song A

directory is created and mp3 made, named correctly etc

mp3 is of the correct song

I grab song b

directory yada yada but when mp3 is written, it correctly writes the mp3 for song b in directory b - then replaces the mp3 for song a with the same data. So now I have directory a, containing an mp3 labelled a, which is actually song b. I also have directory b, containing mp3 b, which is actually b.

When I left it on cruise overnight it seemed to do this for 5-6 songs in a row before breaking out of whatever is going on. Does anyone have any suggestions?

nergal

Link to comment
Share on other sites

I have some weird issues while saving tracks from Pandora. It only saves the 1st track everytime I boot up my PC. Looking into the debug file, I found the following:

DEBUG Thread-2 util.Mp3Processor - recent non mp3 file found: pandoras-jar-beta-patched-by-proge-1.zip - will continue to next file

DEBUG Thread-2 util.Mp3Processor - file java_install_reg.log is not an mp3

DEBUG Thread-2 util.Mp3Processor - no more mp3 found in dir

DEBUG Thread-2 util.Mp3Processor - sleeping for a second

WARN Thread-2 properties.DefaultProperties - Unable to load tmp mp3 retry count property.

DEBUG Thread-2 util.Mp3Processor -

***processing directory: Temp***

Wonder if it points to anything. Can someone please help on this.

I am using 7.3.1 with Java 1.5 on a Win2k machine

Cleared cache, I'm using Macromedia 8.0 but still stuck with the same problem. Can anyone help?

Link to comment
Share on other sites

I'm new BUT, I have READ every page in this thread plus the Noobs guide!

I can't get it to grab anything. It plays and visually everythng looks OK. Has it changed again :?: Or Am I missing something stupid simple?

Beta 7.3.1

FF 1.5.0.7

Macromedia Player 8

J2SE 1.5.0.80

PandorasJar.log:

INFO main client.Client - initing app

INFO Thread-2 server.Server - running

INFO Thread-2 server.Server - Welcome to Pandora's Jar

INFO Thread-2 server.Server - Attempting to lauch on port 8085...

INFO Thread-2 server.Server - OK!

INFO Thread-2 server.Server - [ready, lets grab some MP3's!!!]

INFO Thread-2 server.Server - localhost connected to server.

INFO Thread-2 server.Server - handling request

INFO Thread-2 server.Server - processing url: GET / HTTP/1.1

INFO Thread-2 servlet.ProcessAction - processing static request. path: GET / HTTP/1.1

INFO Thread-2 servlet.ProcessAction - path =

INFO Thread-2 servlet.ProcessAction - documentType = HTML

INFO Thread-2 servlet.ProcessAction - fileType = HTML

INFO Thread-2 server.Server - localhost connected to server.

INFO Thread-2 server.Server - handling request

INFO Thread-2 server.Server - processing url: GET /js/prototype-1.4.0.js HTTP/1.1

INFO Thread-2 servlet.ProcessAction - processing static request. path: GET /js/prototype-1.4.0.js HTTP/1.1

INFO Thread-2 servlet.ProcessAction - path = js/prototype-1.4.0.js

INFO Thread-2 servlet.ProcessAction - documentType = JS

INFO Thread-2 servlet.ProcessAction - fileType = JS

INFO Thread-2 server.Server - localhost connected to server.

******deleted this section for bandwidth sake********

INFO Thread-2 server.Server - handling request

INFO Thread-2 server.Server - processing url: GET /process?action=grab&artist=Nickelback&title=How%20You%20Remind%20Me&album=&genre=&comment=ripped%20by%20[PaNDoRas%20jAR]%20your%20source%20for%20listening%20pleasure&year=&cruise=off&albumImgLocaction=&pandoraUserName=&stationId=&cddbLookUp=off&addToItunes=off&_= HTTP/1.1

INFO Thread-2 servlet.ProcessAction - handling mp3 request

INFO Thread-2 util.Mp3Processor - locating mp3

INFO Thread-2 server.Server - unable to rip MP3

java.lang.RuntimeException: unable to find file make sure you have Pandora running in a FIRFOX browser

at util.Mp3Processor.findUserTmpDir(Mp3Processor.java:139)

at util.Mp3Processor.findCurrentMP3(Mp3Processor.java:25)

at servlet.ProcessAction.handleMP3Request(ProcessAction.java:30)

at server.Server.handleHTTPRequest(Server.java:110)

at server.Server.run(Server.java:83)

INFO Thread-2 server.Server - unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser

Link to comment
Share on other sites

I figured it out :shock: I guess all the coding in the 70 pages of this post got to me.

Turns out I was running Macro Media 9 :evil: all along. In the future for other noobs, right mouse click on the pandora "frame". See if it comes up with:

Settings...

About Macromedia Flash Player 8...

If not, refer to http://www.hak5.org/forums/viewtopic.php?t=983 about un-installing 9 & installing 8.

I noticed that, the light bulb went on, made the change and it works! I'll shut up now.....

Link to comment
Share on other sites

Guest t3chn0b0y
I figured it out :shock: I guess all the coding in the 70 pages of this post got to me.

Turns out I was running Macro Media 9 :evil: all along. In the future for other noobs, right mouse click on the pandora "frame". See if it comes up with:

Settings...

About Macromedia Flash Player 8...

If not, refer to http://www.hak5.org/forums/viewtopic.php?t=983 about un-installing 9 & installing 8.

I noticed that, the light bulb went on, made the change and it works! I'll shut up now.....

thanks for helping the n00bs. i didn't respond because i was caught up getting other things done around here.. and it seems like the same questions are being asked over and over again. :idea: somewhere we need more information on the newer jar's and how to get these issues addressed without explaining it over and over.. my apologies for being a bit on the grumpy ars side..

Link to comment
Share on other sites

I figured it out :shock: I guess all the coding in the 70 pages of this post got to me.

Turns out I was running Macro Media 9 :evil: all along. In the future for other noobs, right mouse click on the pandora "frame". See if it comes up with:

Settings...

About Macromedia Flash Player 8...

If not, refer to http://www.hak5.org/forums/viewtopic.php?t=983 about un-installing 9 & installing 8.

I noticed that, the light bulb went on, made the change and it works! I'll shut up now.....

Yeah I did that, still didn't work

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...