Jump to content

Pandora Timeshifting App: Main Discussion Thread


Recommended Posts

  • Replies 1.4k
  • Created
  • Last Reply

Top Posters In This Topic

Pnadora update

Yea - Josh is right Pandora updated to a new version - do as he suggested and you'll be fine.

Also I have a release available with the update

http://www.tengbob.com/pandoras-jar-beta.3.b.zip

It might be easier just to update the HTML manualy.

Also in a future release I will write some logic to ping the swf and try to determine the correct version server side in case of future updates, probable a script that pings the swf and increments version numbers untill it finds one that exist - I will have to write some sort to tokenized support to inject the param server side into the HTML or do it in javascript in an onLoad function that makes an AJAX request to get the SWF location.

cheers

Link to post
Share on other sites

I have everything correctly installed, yet I am getting this error in my logs:

INFO Thread-2 server.Server - processing url: GET /process?action=grab&artist=The%20Red%20Walls&title=Home&album=&genre=&comment=ripped%20by%20[PaNDoRas%20jAR]%20your%20source%20for%20listening%20pleasure&year=&cruise=on&albumImgLocaction=&pandoraUserName=&stationId=15862717&cddbLookUp=off&_= HTTP/1.1

INFO Thread-2 servlet.ProcessAction - handling mp3 request

INFO Thread-2 util.Mp3Processor - locating mp3

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

... has anyone else had this problem? I'm running Java 1.5.0 through FF, I've had no probs with loading the java app or connecting to local host.

Thanks!

Link to post
Share on other sites

soakedjunk

sometimes the cache on the very first song played lags a little.

wait about a minute and let me know -- the app should make it past this onces but songs are cached

let me know

Link to post
Share on other sites

lol so you no you have been dugg then, i hope pandora dont read digg often. :cry:

EDIT:

Dam, i just tryed the hack again and it doesnt work i hope its just me :cry: :cry: :cry:

Link to post
Share on other sites

Seems to get started right, but it's not creating the MP3 files. Here's the message I get. Any ideas?(And yes, I'm using Firefox)

localhost connected to server.

No enum const class enums.FileType.ICO

localhost connected to server.

unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser

Link to post
Share on other sites

W4RP3D

Still works for me -- did you make the update to the html file?

Extreme_One.. look up two posts.

Find https://www.pandora.com:443/radio/tuner_6_9_0_3.swf in the HTML file, and replace it with https://www.pandora.com:443/radio/tuner_6_9_0_4.swf -- there are two instances of this, so replace both.

Josh

let me know - if your still having problems - is there anything in the log file?

other99

Not sure - I have heard similar complaints with certain version of flash - what version are u on?

also can you type %TEMP% in your run window and confirm you have a dir [plugtmp-some number]

Link to post
Share on other sites
other99

Not sure - I have heard similar complaints with certain version of flash - what version are u on?

also can you type %TEMP% in your run window and confirm you have a dir [plugtmp-some number]

Flash Version = 8,0,24,0

I'm not sure what you are saying about %TEMP%. Do you mean to type this is a DOS window? 'Cause that doesnt work. I did however type SET and saw that my TEMP environment variable was set to C: TEMP. But I dont think this is what you were talking about. Please elaborate. Thanks...

Link to post
Share on other sites
Yea - use the dos window - the command [%TEMP%] should open an explorer window in your temp dir.

Confirm the dir [plugtmp-some number] exist

Let me know

Here's what I get:

C:temp>%TEMP%

'c:temp' is not recognized as an

operable program or batch file.

The C: temp directory does exist, however there's not a plugtmp dir in it.

BUT... I have an env varable called TMP, which points to different temp directory. That directory DOES have the plugtmp dir. Here are the details:

Directory of F:Documents and Settings******Local SettingsTempplugtmp

05/26/2006 02:34 PM <DIR> .

05/26/2006 02:34 PM <DIR> ..

05/26/2006 02:11 PM 3,093,314 access

05/26/2006 02:12 PM 4,470,072 access-1

05/26/2006 02:15 PM 4,552,410 access-2

05/26/2006 02:15 PM 2,948,283 access-3

05/26/2006 02:16 PM 5,331,486 access-4

05/26/2006 02:19 PM 4,361,821 access-5

05/26/2006 02:25 PM 5,174,333 access-6

05/26/2006 02:30 PM 5,119,999 access-7

05/26/2006 02:35 PM 4,050,023 access-8

05/26/2006 02:11 PM 519,546 tuner_6_9_0_4.swf

05/26/2006 02:11 PM 1,023 v5

11 File(s) 39,622,310 bytes

2 Dir(s) 971,153,408 bytes free

Link to post
Share on other sites

hi, im having a bit of problems....... :

Well, i start it up, and it says this,

Welcome to Pandoras Jar

Attempting to lauch on port 80...OK!

[ready, lets grab some MP3's!!!]

localhost connected to server.

localhost connected to server.

localhost connected to server.

localhost connected to server.

localhost connected to server.

localhost connected to server.

localhost connected to server.

..So yeah, this loads up the page at first, but after a minute when i reload it, the page doesnt display.

Anyways, thats not whats troubling me.. When i try to click "Grab it", it doesnt give any errors, but its not ripping the mp3 either. Its saying complete..In the properties file, i uncommented the line, and added the path i wanted(c:pandora).... Its not even creating c:pandoramp3..

I'm not 'computer illerate' or anything.

Oh wait, in the log file, it is giving errors..

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

What should i do? :

Link to post
Share on other sites

Dude3609

quick the app

try lauching from the command window: java -jar pandora.jar

the log

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

this is normal the app is just waiting for the cache to build - let it sit for a bit and it should be happy after a couple of minutes - at most - the delay will normally be just for the 1st song

let me know how it goes

Link to post
Share on other sites

i've lookd through this topic i didn't see this error yet, if i'm wrong just tell me ill look again but just incase heres my problem......

"unable to rip MP3 unable to find file make sure you have Pandora running in a FIRFOX browser"

i AM using Firefox- v1.5.03

Link to post
Share on other sites

could be similar to other99 problem - make sure your %TEMP% env var is assaigned

in the command window - set %TEMP%

if the windows exporer does not come up.

FYI

currently the app only works on windows...

try

try this

in the same command window u used to open up the application

type

set TEMP=%TMP%

this should do the trick

make sure to lauch pandoras jar from the same command window

Link to post
Share on other sites
Dude3609

quick the app

try lauching from the command window: java -jar pandora.jar

the log

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

this is normal the app is just waiting for the cache to build - let it sit for a bit and it should be happy after a couple of minutes - at most - the delay will normally be just for the 1st song

let me know how it goes

thanks, but im still havin problems. I made the batch,

and did what you said, but im still getting spammed with this,

INFO Thread-2 server.Server - processing url: GET /process?action=grab&artist=Blacklisted&title=How%20Quickly%20We%20Forget%20(Again)&album=&genre=&comment=ripped%20by%20[PaNDoRas%20jAR]%20your%20source%20for%20listening%20pleasure&year=&cruise=on&albumImgLocaction=&pandoraUserName=sortheros953(at..edited for forum post)g-mail.com&stationId=24707868&cddbLookUp=off&_= HTTP/1.1

INFO Thread-2 servlet.ProcessAction - handling mp3 request

INFO Thread-2 util.Mp3Processor - locating mp3

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

INFO Thread-2 util.Mp3Processor - access file not found trying again after 1 sec

Even when it switched to the next song.. Its pretty much stuck like that. Bout 100 lines of that access file not found. lol

btw, thanks alot for your help :) I already use pandora as my default music anyways.. But im tired of getting music that sucks, and i got the disk space to build up my own library of music. :)

edit: heres default.properties,

#uncomment the following line to set your preferred storage dir - u can change at at runtime if u want

mp3.archive.path=c:pandora

Link to post
Share on other sites

Quick question...

Is there a way to change the 15 second lead time before saving the MP3? Maybe by manually supplying an argument or something?

I'm asking because, sometimes, with some songs, you've gotta hear more than 15 seconds to decide if you like it or not. I'm finding songs that start with some kinda intro and don't even really get started until maybe 30 secs or a minute into it. It'd be nice if I didn't have to go back and delete the MP3 that got created after 15 seconds.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...